[ALOY-914] Default Alloy Project shows incorrect appicon

GitHub Issuen/a
Resolution Date2014-11-26T22:41:18.000+0000
Affected Version/sAlloy 1.3.0
Fix Version/sAlloy 1.4.0, Alloy 1.3.1, 2014 Sprint 03
ComponentsTitanium SDK
Labelsqe-3.2.0, qe-manualtest, regression
ReporterPriya Agarwal
AssigneeTony Lukasavage


Steps to reproduce: 1)Create any default alloy project and install on device. Expected Result: Alloy app icon must be displayed on the device. Actual Result: Instead of Alloy app icon classic app icon is being displayed on device. Tried with current alloy release version alloy@1.3.0,getting the incorrect app icon for alloy project when installing on device. But by changing Studio using Studio: correct alloy app icon is being displayed on device.


  1. Ingo Muschenetz 2013-12-24 Priya, when you tried Studio 3.1.4, which versions of CLI and SDK were you using?
  2. Priya Agarwal 2013-12-26 Used Sdk:3.2.0.GA and CLI 3.2.0
  3. Thomas Huelbert 2013-12-27 Priya, please check this using an all 3.1.4 configuration (3.1.4 sdk and ide + 1.3.1 alloy) when you can
  4. Priya Agarwal 2013-12-30 Have checked with configuration: Appc-Studio: Sdk:3.1.3.GA acs:1.0.11 alloy:1.3.1-alpha npm:1.3.2 titanium:3.1.2 titanium-code-processor:1.0.3 Osx: Mountain Lion 10.8.5 Am still getting the incorrect app icon for alloy project.
  5. Allen Yeung 2013-12-31 I could not get the correct icon either in older versions such as 3.1.3.GA. I downgraded alloy, CLI, and SDK. Here's what I found: If you import a sample from studio, the icons are correct for the alloy samples. After talking with the studio team, it looks like for samples.. studio will manually copy over the sample, including the icons. For template studio will do something like:
       "/usr/local/bin/alloy" "new" "/Users/ayeung/Documents/Appcelerator_Studio_Workspace/template" "two_tabbed"
    I'm not sure if alloy is supposed to copy the alloy app icon over during the new command, but the current behavior is that it doesn't. The only real reference I see to the alloy app icon is at https://github.com/appcelerator/alloy/blob/58e4553ac86e48a62e395cb05b52afdb066171b6/Alloy/commands/info/index.js and I'm not sure how this is used during project creation. [~tlukasavage], Could you take a look at this and provide some guidance?
  6. Praveen Innamuri 2013-12-31 PRs: master: https://github.com/appcelerator/alloy/pull/290 1_3_X: https://github.com/appcelerator/alloy/pull/289
  7. Federico Casali 2014-01-07 Verified fixed. Icon displayed is the Alloy App Icon. TiSDK 3.2.1.v20140106195644 Appcelerator Studio Alloy 1.3.1-beta2 Android Google Nexus Galaxy 4.3 iPhone 5 iOS7 Closing.
  8. Priya Agarwal 2014-02-06 Reopening the issue as we encounter again with the bug with environment: Appcelerator Studio, build: SDK build: 3.2.1.v20140205094854 acs@1.0.12 alloy@1.3.1-cr2 npm@1.3.2 titanium@3.2.1-beta3 titanium-code-processor@1.1.0 OS:Ubuntu(12.04),Windows(8)
  9. Tony Lukasavage 2014-02-06 [~pagarwal] what platform are you targeting? What device? Does this apply to sim/emulator too?
  10. Tim Poulsen 2014-02-06 Alloy: 1.3.1-cr2 CLI: 3.2.1-beta3 SDK: 3.2.1.v20140205094854 Tested with CLI: 1) ti create --platforms android,ios -n ALOY914 --id com.appcelerator.alloy914 2) in alloy914 directory, alloy new . 3) ti build --platform ios -- got the Alloy icon 4) ti build --platform android --target device -- installed to Galaxy Nexus (4.2.2) -- got the Alloy icon Tested with Appcelerator Studio 1) Create a new project in Studio 2) Run on Device (Galaxy Nexus) -- got the Alloy icon My version of Studio is ahead of the tested version. Sorry, it's what the preview site said was available as an upgrade for me.
  11. Tim Poulsen 2014-02-06 New test, same Alloy & CLI environment as before 1) Uninstalled Studio 3.3.x and installed Appcelerator Studio 2) Removed app from Galaxy Nexus 3) Cleaned project in Studio 4) Built & installed to Galaxy Nexus. I get the Alloy app icon 5) Built & installed to iPhone simulator. I get the Alloy app icon
  12. Tim Poulsen 2014-02-06 Cannot reproduce using latest reported failing configuration as well as others tested.
  13. Wilson Luu 2014-02-06 We were not able to reproduce this issue in the following environment: Appcelerator Studio, build: SDK build: 3.2.1.v20140205094854 CLI: 3.2.1-beta3 Alloy: 1.3.1-cr2 Xcode: 5.0.2 OS: Mavericks (10.9.1), Mountain Lion (10.8.5), Windows 8, Ubuntu 12.0.4 Devices: iphone 5c (7.0.4), Nexus 5 (4.4.2), Nexus Galaxy Note 2 (4.1.2), Sony Xperia (4.1.2) *However,* we were able to reproduce this issue with current 3.2.1 stack plus Windows 8.1 with Droid 3 (2.3.4), Samsung Galaxy S3 (4.0.4), Sony Xperia (4.1.2), and Nexus 5 (4.4).
  14. Tim Poulsen 2014-02-06 Reopening due to failure on Windows 8.1
  15. Tim Poulsen 2014-02-06 I have no way to test this to verify. I don't have a Windows system.
  16. Tony Lukasavage 2014-02-06 Cannot reproduce the issue from the command line using: * Windows 8.1 * Android 4.4.2 + Galaxy Nexus emulator * TiSDK 3.2.1.v20140205094854 * CLI 3.2.1-beta3 * Alloy 1.3.1-cr2
        ti create aloy914 
        cd aloy914
        alloy new .
        ti build -p android
    I will try again using Appcelerator Studio and its templates to see if those are the true source of the issue.
  17. Tony Lukasavage 2014-02-06 Still can't reproduce with the setup of the prior comment, and including Appcelerator Studio, while following the exact steps noted in the original description. App icons, splash screens, etc... are all the ones you would expect for Alloy.
  18. Tony Lukasavage 2014-02-07 master: https://github.com/appcelerator/alloy/pull/334 1_3_X: https://github.com/appcelerator/alloy/pull/333 functional testing instructions are noted in the description.
  19. Tony Lukasavage 2014-02-07 fixes confirmed
  20. Priya Agarwal 2014-02-07 Verified the fixed. With Environment: Appc Studio: Sdk:3.2.1.v20140206170116 alloy:1.3.1-cr3 titanium:3.2.1-beta4 acs:1.0.12 titanium-code-processor:1.1.0 Osx: Windows,Ubuntu Device: Nexu4(v4.1.1) Could see the alloy icon on both emulator and device.Hence closing the issue.
  21. Priya Agarwal 2014-02-07 Verified fixed on Mac(10.9) Maverick also. With environment: Appc Studio: Sdk:3.2.1.v20140206170116 alloy:1.3.1-cr3 titanium:3.2.1-beta4 acs:1.0.12 titanium-code-processor:1.1.0 Osx: Maverick 10.9 Device: Nexu4(v4.1.1) Working fine

JSON Source