Titanium JIRA Archive
Titanium SDK/CLI (TIMOB)

[TIMOB-1353] Unable to Use Custom Fonts

GitHub Issuen/a
Resolution Date2011-04-15T02:50:15.000+0000
Affected Version/sn/a
Fix Version/sn/a
Labelscustom, font, fontfamily
ReporterClifton Labrum
AssigneeJeff Haynie


Instructions for using custom fonts are given here:

http://developer.appcelerator.com/blog/2010/04/adding-custom-fonts-to-ipad.html"> http://developer.appcelerator.com/blog/2010/04/adding-custom-fonts-...

Comments on those posts, as well as this one indicate that this functionality doesn't work:
http://developer.appcelerator.com/question/32691/use-custom-font-for-label"> http://developer.appcelerator.com/question/32691/use-custom-font-fo...

I, personally, have tried everything and cannot get this to work.

Something must have happened since SDK 3.2 when this was originally available that breaks this functionality.

Please provide a fix as soon as possible.

Thank you!


  1. Jeff Haynie 2011-04-15

    I updated blog with how to do this in 1.3+

    http://developer.appcelerator.com/blog/2010/04/adding-custom-fonts-to-ipad.html"> http://developer.appcelerator.com/blog/2010/04/adding-custom-fonts-...

  2. Clifton Labrum 2011-04-15

    Do you have a living, breathing version of this code where it actually works? I had already tried the info.plist fix and it still doesn't work.

  3. hal 2011-04-15

    Just in case anyone else needs it, there is a post in the Q&A by Rafael Hernandez that includes a video tutorial on how to do this, that a number of people have found useful. I post it here just in case anyone else needs it.

    http://developer.appcelerator.com/question/49151/custom-font-solution"> http://developer.appcelerator.com/question/49151/custom-font-solution

  4. Lee Morris 2017-03-09

    Closing ticket as invalid.

JSON Source