Titanium JIRA Archive
Titanium SDK/CLI (TIMOB)

[TIMOB-2184] Kitchensink 1.4 does not compile on windows x64

GitHub Issuen/a
Resolution Date2011-04-17T01:58:20.000+0000
Affected Version/sn/a
Fix Version/sRelease 1.5.0
ReporterAnders H.
AssigneeDon Thorp


Compilation ends with

[ERROR] C:\android-sdk\tools\zipalign.exe Unable to open 'C:\KitchenSink\build\android\bin\app.apk' as zip archive

This was a fresh install with java for 64 bits, I have not seen this with the 32-bit java version on another win7 x64 machine.

Kitchensink 1.3 does compile fine and runs nicely in the simulator. Titanium SDK is 1.4.0

Here is the same error reported -
http://developer.appcelerator.com/question/63001/kitchensink-win64-wont-emulate"> http://developer.appcelerator.com/question/63001/kitchensink-win64-...
http://developer.appcelerator.com/question/66931/error-building-kitchensink"> http://developer.appcelerator.com/question/66931/error-building-kit...
http://developer.appcelerator.com/question/46891/i-cant-even-run-kitchensink-sample-code"> http://developer.appcelerator.com/question/46891/i-cant-even-run-ki...


  1. Don Thorp 2011-04-15

    Android tooling doesn't support 64 bit Java.

    It looks like you've possibly gotten in a bad state with all of the different platforms you've tried. Please get rid of Android 1.5 platform and Google API. Get rid of all Titanium AVDs (run the android command). Touch, make a small edit and save, your tiapp.xml to force a full build.

    I'll leave this open for now, but in general I close them as invalid.

  2. Anders H. 2011-04-15

    That solved it. Thanks.

    The Getting started document actually claims that you can do the 64-bit java install. http://assets.appcelerator.com.s3.amazonaws.com/docs/GettingStartedTitanium_Windows.pdf"> http://assets.appcelerator.com.s3.amazonaws.com/docs/GettingStarted...

    It does mention on the last page that you might need to do something to the AVDs, but that is very "fluffy" and I did not understand it at all. This should definitely go to the troubleshooting part of that document. (put in the editing of the tiapp.xml if that is needed)

    Best regards, /Anders H.

  3. Don Thorp 2011-04-15

    Forwarded to Documentation.

JSON Source