Titanium JIRA Archive
Titanium SDK/CLI (TIMOB)

[TIMOB-5348] iOS: Phone>App badge, setting app badge has no effect on iOS5

GitHub Issuen/a
Resolution Date2017-05-26T17:29:23.000+0000
Affected Version/sRelease 1.7.2
Fix Version/sn/a
Labelscore, os-ios5, qe-ios112911
ReporterEric Merriman
AssigneeEric Merriman


Description: While testing KS 172 on iOS 5, Phone>App badge, I pressed the button to set app badge and left KS to check the result. Nothing occurred. I tried several times. Steps to Reproduce: 1) Install KS with SDK 1.7.2 onto iOS 5 device 2) Navigate to Phone>App badge 4) Tap "set app badge" 5) Return to iPhone home menu to set the result Results: No app badge on KS icon Expected results: App badge on KS icon Note: Does not occur with iOS 4.3x OCCURS with SDK 1.8.0.v20110922105247


  1. Sabil Rahim 2011-09-30

    This is a very strange bug, which only happens on AT&T iphone 4 device and only for a particular appid : "com.appcelerator.titanium" and works fine if the appid is changed to anything else the appbadge and notification seems to work fine. Solution to this would be to wipe out the device and reinstall the device with the new iOS5 release. and re-check if the bug occurs.
  2. Reggie Seagraves 2011-09-30

    Please regress on the device after it has been wiped and reinstalled.
  3. Eric Merriman 2011-12-02

    This is still occurring with SDK on an iPhone 4s Sprint. A few notes: The iOS setting for notifications regarding badges must be on. App badge from KS>Phone>App Badge does function, it's just the app badge setting from push that does not. All 3 push tests work, just not the app badge ONLY on iOS 5. I ran some experiments and the app badge will work on iOS 5 if you wipe and restore the device then install KS and perform the test. On non-5 devices deleting then install a new KS in preparation for the push test sometimes shows the last app badge sent to the app, indicating something is persisting through app uninstall and reinstall. This does not occur with iOS 5, but may be related.
  4. Blain Hamon 2011-12-02

    A few notes of interest: According to http://developer.apple.com/library/ios/technotes/tn2265/_index.html#//apple_ref/doc/uid/DTS40010376-CH1-TNTAG42 , you need to wait a day/set the clock forward to ensure that the permissions are fully reset. According to https://devforums.apple.com/message/586887 , this isn't working. https://devforums.apple.com/thread/133659?tstart=0 is having the same issue, but does not have a response. https://devforums.apple.com/message/559314#559314 is having similar problems. And now, apple's servers are not responding to wanting a push notification. It's very possible that this is to be put on hold as an Apple issue.
  5. Stephen Tramer 2011-12-04

    Bumping to Sprint 49. Not identified as a regression, we strongly suspect it's an Apple issue, and it could take some time to confirm.
  6. Blain Hamon 2012-01-10

    Talked with Stephen Tramer on this one, and since we have not been able to easily reproduce, and more importantly, haven't seen any issue like this in the field, let's resolve this one as 'on hold'. Given that the above threads had no updates, it's likely that this will become moot in time.
  7. Eric Merriman 2012-01-25

    My latest push test showed the app badge working as expected for iOS 5.0.1 devices. I attempted to reproduce this with the included steps on this bug for the following devices: iPhone 4s (verizon 5.0.1) iPhone 4s (Sprint 5.0.1) iPad 2 (5.0.1) With SDK 1.8.1.v20120123130147. After discussing with Thomas, setting as no longer able to reproduce and closing.
  8. Eric Merriman 2012-03-30

    This is an ongoing issue now including 5.1 devices (So 5.0+). I checked all the apple developer links included with this ticket and none have any resolution, but most seem to relate to the default setting for badges of "off" for 5.0. I think it would be good to evaluate this issue again to see if there is something we are missing on our side. To reiterate: Setting badge from KS works, but not via push. I did set ensure the push notification setting for "badge" was set to "on" on 5.0+ devices. Push notifications intercepted while KS is running seem well formed. Push notifications with KS backgrounded and not running both exhibit the problem. 4.x devices do not have this problem.
  9. Blain Hamon 2012-08-08

    If the OS has the app badge setting to off, there's not much we can do. But if it's on, hrm. That's odd. I'd expect the app to have the same issue while not running in 4.0 as 5.0, since during that time, no Appcelerator-made code is running. Perhaps we should revisit what the push packet should look like, and the likelihood that 5.0 is more strict with the property setting than 4.0 was?
  10. Blain Hamon 2013-01-30

    Belated realization: I think I recall when Apple was talking about newsstand notifications, that push notifications can be throttled while the app is in the background. It might have been related to that.
  11. Lee Morris 2017-05-26

    Closing ticket as Invalid as this version of Kitchen Sink is no longer supported.

JSON Source