Titanium JIRA Archive
Titanium SDK/CLI (TIMOB)

[TIMOB-60] iOS: TM won't build when there's an apostrophe in folder names

GitHub Issuen/a
Resolution Date2012-07-11T23:46:03.000+0000
Affected Version/sRelease 1.6.0
Fix Version/sRelease 2.1.0
Labelscore, module_build, qe-testadded
ReporterChristopher Mahoney
AssigneeNeeraj Gupta


I had this problem with Titanium Mobile 0.5.0 and 0.5.2.

I originally put my project in a folder that had an apostrophe in it. But when I tried to run "launch app" under the "test & package" tab in Titanium Developer, I got this message:

sh: -c: line 0: unexpected EOF while looking for matching ''<br/> sh: -c: line 1: syntax error: unexpected end of file<br/> App Spec: specified by path /Chris's Folder/mobiletest/build/iphone/build/Debug-iphonesimulator/mobiletest.app<br/> SDK Root: path=/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator3.0.sdk version=3.0 name=Simulator - iPhone OS 3.0<br/> Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=1 UserInfo=0x2214c0 "Unknown error."One moment, building ...<br/> kill simulator called<br/> signal caught: 3<br/> calling log kill on 2044<br/> kill simulator called

I also got an Apple warning with a yellow triangle that said:

"The Application Python Quit Unexpectedly, Mac OSX and other programs are not affected" (the usual screen you get when one of your programs quits without warning).

It took a couple hours to figure it out, but once I put the project in a folder that didn't have an apostrophe (or space) it built correctly. Perhaps you could have a look, maybe make it more clear that you can't have an apostrophe anywhere in the path to your Titanium Mobile files? Thanks a million; I love your program.


  1. Stephen Tramer 2011-04-15

    Still valid, after all these years. Can be solved by escaping quote characters.

  2. Marshall Culpepper 2012-04-05

    Tested against latest master, and this seems to be resolved now (2.1.0)
  3. Dustin Hyde 2012-06-14

    Closing as Fixed. SDK: 2.1.0.v20120613210250 Studio: OS: Snow Leopard Devices Tested: iPhone Simulator 5.0 Xcode: 4.2 Steps to Test: 1. Create a folder with an apostrophe in the name. 2. Add a titanium mobile project to that folder. 3. Import the project into studio and deploy to ios simulator. Expected Result: App deploys correctly.
  4. Anshu Mittal 2012-07-11

    Reopening to update labels

JSON Source