Titanium JIRA Archive
Titanium SDK/CLI (TIMOB)

[TIMOB-2591] iOS, unable to build KS in 1.5.1 (install errors)

GitHub Issuen/a
Resolution Date2011-12-29T17:49:06.000+0000
Affected Version/sn/a
Fix Version/sBacklog
Labelserror, install, ios, regression, reported-1.5.1, reported-1.6.0
ReporterThomas Huelbert
AssigneeReggie Seagraves


most recent 1.5.X pull -

blocks testing of 1.5.1

1.git pull and scons to 1.5.1
2.install into and launch TiDev
3.import KS and try to publish

Install Error

Error: Traceback (most recent call last): File "/Library/Application Support/Titanium/mobilesdk/osx/1.5.1/iphone/builder.py", line 1143, in main

execute_xcode("iphoneos%s" % iphone_version,args,False)

File "/Library/Application Support/Titanium/mobilesdk/osx/1.5.1/iphone/builder.py", line 925, in execute_xcode

output = run.run(args,False,False,o)

File "/Library/Application Support/Titanium/mobilesdk/osx/1.5.1/iphone/run.py", line 31, in run


SystemExit: 1

works in 1.6.0, I am able to create other simple projects and install them with thei same 1.5.1 build


  1. Thomas Huelbert 2011-04-15

    Nope, bad bug, this is seen in using any build (tried 1.5.0 - 1.6.0), it still blocks 1.5.1 testing.

  2. Thomas Huelbert 2011-04-15

    did a new install of TiDev and install to device fails with the same error (new install came as 1.2.2). I am able to launch the app in simulator without error.

  3. Thomas Huelbert 2011-04-15

    added reported tags

  4. Thomas Huelbert 2011-04-15

    New steps:

    1.Select dev cert that does not map to the dev id on the profile and try to install to device

    results: series of cryptic errors

    expected: useful error messaging.

    moved to 1.6.0 and lowered priority to low as this is an existing issue.

  5. Blain Hamon 2011-04-15

    This is nontrivial, and as per Ralf, we're going to R&D it, but it probably won't make it to 1.6.

  6. Stephen Tramer 2011-12-29

    Legacy bug. References both 1.5 and TiDev, neither of which are still supported. Marking invalid.
  7. Lee Morris 2017-03-02

    Closing ticket as invalid.

JSON Source