Titanium JIRA Archive
Appcelerator Community (AC)

[AC-1054] Titanium Module Creation gives permission denied error

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2014-07-08T00:27:43.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAppcelerator Modules
Labelsios, module,
AssigneeMauro Parra-Miranda


When I try to create iOS Module using command *titanium.py create --platform=iphone --type=module --dir=~/tmp/ --name=test --id=com.example.test* I get this error *OSError: [Errno 13] Permission denied: '/Users/apple/Library/Developer/Xcode/Templates/Application/File Templates/Appcelerator/TiProxy.xctemplate/___FILEBASENAME___.h'* I dunno why this occurs though I have created given all folders 777 permission. Of course module project gets created but when I build it fails. Moreover, whenever I start Titanium Studio I'm getting updation found for CLI. I do select update option however the same thing happens if I restart Titanium Studio. I can't figure what exactly is the problem.


  1. Chris Barber 2014-05-12

    This sounds like a permission issue with the destination folder. To fix, try running the following from the Terminal:
       sudo chown -R whoami ~/Library/Developer
    You can try manually creating the directory:
       mkdir -p ~/Library/Developer/Xcode/Templates/Application/File\ Templates/Appcelerator
    Finally, recreate the module and it should copy the templates into the correct location.
  2. Kirthika 2014-05-13

    Thanks Chris Barber. This worked for me. But I still get Titanium update pop up each time I open Titanium Studio.
  3. Mauro Parra-Miranda 2014-07-08

    Can't reproduce, the workaround was useful for the customer.

JSON Source