Titanium JIRA Archive
Appcelerator Community (AC)

[AC-1175] Android map module doesn't update when panning around and zooming

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2014-08-08T07:01:10.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAppcelerator Modules
Labelsandroid, ti.map
ReporterJimmie Jönsson
AssigneeMauro Parra-Miranda


The map won't update for Android when panning around and zooming in on a different location. Im having the same problem with both the Development key (shipped with Titanium) and the Distribution key. It seems like the application is caching the map somehow, as the map at start (Sydney, Australia) is COMPLETELY blurred, while if I move the map to Karlstad, Sweden, the map is fine even when zoomed, a lot. Karlstad is the first location used for my map, so I guess thats why. If I create a whole new application, the Development API key for Google maps (shipped with Titanium) works fine, but the issue remains with the Distribution key (What? Shouldn't work at all?). app.js now contains the following, and nothing more: //
var MapModule = require('ti.map');
var win = Ti.UI.createWindow({backgroundColor: 'white', title: 'Title', navBarHidden: true});

var mapview = MapModule.createView({
    mapType: MapModule.NORMAL_TYPE,
    region: {latitude: -33.87365, longitude: 151.20689, latitudeDelta: 0.1, longitudeDelta: 0.1 }, //Sydney
    userLocation: true,
    annotations: [],
    animate: false

Im not sure if this is an issue you can address, or if this is an issue for Google rather than you, but I thought that I'd start here and see what you have to say. This application is currently sitting on Google Play, so a quick answer would be greatly appreciated. Many thanks in advance. Regards, Jimmie Jönsson


  1. Harish Mridha 2014-07-22

    Hi, We tried to reproduce this issue with a sample test case. It’s working as expected with Titanium SDK 3.1.3.GA and 3.3.0.GA.


    Titanium SDK: 3.1.3.GA and 3.3.0.GA Titanium CLI: 3.3.0 OS X Version: 10.9.3 Android API Level: 17 and 19


       var MapModule = require('ti.map');
       var win = Ti.UI.createWindow({
       	backgroundColor : 'white',
       	title : 'Title',
       	navBarHidden : true
       var mapview = MapModule.createView({
       	mapType : MapModule.NORMAL_TYPE,
       	region : {
       		latitude : -33.87365,
       		longitude : 151.20689,
       		latitudeDelta : 0.1,
       		longitudeDelta : 0.1
       	}, //Sydney
       	userLocation : true,
       	annotations : [],
       	animate : false


    - Create a simple project. - Update app.js with test code - Add Map module in tiapp.xml - Run on android device


    It’s working as expected. Thanks
  2. Jeremy Sculfort 2014-07-22

    Hi, I'm having the very same problem with Ti 3.3.0 and Ti.Map 2.1.6 Thanks for your efforts
  3. Mauro Parra-Miranda 2014-07-28

    Hello [~jimmie]! Can you please take a look into the posted testcase and let me know your results. Best Regards, Mauro
  4. Mauro Parra-Miranda 2014-08-08

    Tested on 3.3.0.GA, works fine.
  5. Jimmie Jönsson 2014-09-19

    Hello Mauro Parra-Miranda. Im terribly sorry that I haven't answered this post earlier. I had bound my Jira account to a mail that I don't use that often (while thinking it was to my work mail) so haven't noticed your inputs. I also started working on a different project for a while so this project got forgotten, until now. I've tested the test case, and it works as expected. Although, while running my old code, the map no longer loads at all until you zoom out, and then the whole map is all blurry (and by "all blurry" I really mean blurry, you can't see a thing, only like.. silhouettes of countries) This is when I run the application via Titanium on Android Device. If I remove the Application, and instead download it from Google Play, it works fine again. I have no idea if it will come back eventually, but it works for now. Thank you. Regards, Jimmie

JSON Source