Titanium JIRA Archive
Appcelerator Community (AC)

[AC-1185] xcode not recognised

GitHub Issuen/a
Resolution Date2014-05-16T18:11:31.000+0000
Affected Version/sn/a
Fix Version/sn/a
ReporterDean Johnson
AssigneeRitu Agrawal


Steps to Reproduce

Installed xode (latest version) and then clicked the install or update iOS or SDK button. It found the installation path but when returned back to the menu. I then read on a post online that it works with xcode version 5. I installed this and tried again but the same thing happened. I verified that xcode opened and work standalone on both versions

Actual Result

iOS was not recignised as being installed by titanium.

Expected Result

iOS to be ready to build an application with


Screen Shot 2014-05-15 at 13.30.07.png2014-05-15T12:31:54.000+0000569900
Screen Shot 2014-05-15 at 13.30.16.png2014-05-15T12:31:54.000+0000781178


  1. Ritu Agrawal 2014-05-14

    I looked at your log files and couldn't see the Xcode version. Please take a look at the documentation guide and also the supported version of Xcode with Titanium SDK. http://docs.appcelerator.com/titanium/latest/#!/guide/Installing_the_iOS_SDK Also, please attach the output of the following command to diagnose the issue further ti info -t ios
  2. Dean Johnson 2014-05-15

    Hi Ritu, Please see the below information. Titanium Studio, build: Xcode Version: Version 5.1.1 (5B1008) ti info -t ios gives this message: FATAL ERROR: Error: Unable to parse config file I checked the link that you gave me and this seems to be ok. Thank you for your help. Dean Johnson
  3. Dean Johnson 2014-05-15

    I have uninstalled Xcode but I am getting this from titanium. Please see the attached screenshots. It appears to be finding Xcode even when it is not installed. I have also used app cleaner to remove Xcode and the problem still remains as shown. Errors are being thrown up by Titanium when creating a new project. It is like something is not installed correctly. I have checked Java and Node.js and they are installed, I uninstalled titanium studio with app cleaner also to remove any files which may have been missed. I hope this is enough information for you.
  4. Dean Johnson 2014-05-15

    I tried to install the Tizen SDK. This installed ok but when I tried to create a project I got an error with the configuration file. It seems like there is a configuration problem with Titanium itself even though I have installed it completely from scratch a couple of times now.
  5. Ritu Agrawal 2014-05-15

    Can you please attach the output of the "titanium info" command from the terminal? This will help us diagnose the issue further.
  6. Ritu Agrawal 2014-05-15

    Also, found the related Q&A thread that might be helpful https://developer.appcelerator.com/question/161934/issue-with-starting-app-in-titanium-studio
  7. Dean Johnson 2014-05-16

    You may close this ticket down now. I rebuilt my mac and managed to get it installed and working ok Thank you for your help
  8. Ritu Agrawal 2014-05-16

    Great! Glad to know that things are working for you. Let us know if you run into any other issues.

JSON Source