Titanium JIRA Archive
Appcelerator Community (AC)

[AC-1285] [ERROR] : Invalid "--device-id" value ""

GitHub Issuen/a
Resolution Date2014-07-21T23:24:29.000+0000
Affected Version/sn/a
Fix Version/sn/a
Reportertomaz bracic
AssigneeShuo Liang


When I try to build an app to a actual device (iPhone 5) iOS 7.1 i get the error message: [ERROR] : Invalid "--device-id" value "" I have provisioning, certificates, etc all ok.


  1. Shuo Liang 2014-07-21

    Hi, Would you please try to restart the studio and clean building the project from menu, then after that connect your device to machine and try to run it. Hope this will help you. Regard, Shuo
  2. tomaz bracic 2014-07-21

    Hi, thanks for you quick response. The suggested actions did not helped me. The get the same error. Regards, Tomaz
  3. tomaz bracic 2014-07-21

    I tried with one older project of mine. It was build with 3.1.3 GA, and this one builds well. If I change to 3.2.1 GA and 3.3.0 GA it won't. And I did Project clean in between. Hope this info helps in a way...
  4. tomaz bracic 2014-07-21

    Fixed it myself. It looks like the problem was, that CLI titanum had old SDK version... when I selected 3.3.0.GA as my default... everything worked. I was able to select device inder Run Configuration. Thanks anyway. :/

JSON Source