Titanium JIRA Archive
Appcelerator Community (AC)

[AC-1391] [ERROR] : Invalid '--ios-version' value '7.0.3'

GitHub Issuen/a
Resolution Date2014-03-12T05:25:17.000+0000
Affected Version/sn/a
Fix Version/sn/a
ReporterSrdjan Lukic-Bardak
AssigneeRitu Agrawal





  1. Ritu Agrawal 2014-03-11

    Can you please let us know your OS information and what Titanium SDK version you are choosing in your tiapp.xml file?
  2. Srdjan Lukic-Bardak 2014-03-11

    I'v tryed to build with : 3.1.3.GA, 3.2.1.GA, 3.2.1.GA, 3.2.1.GA and even 3.3.0.v20140310170858. As I can se my simulator is sat to iOS SDK : 7.0.3, Simulator version 7.0.3. And I get that error on clean and old projects.
  3. Ritu Agrawal 2014-03-11

    Can you please attach the output of the following commands to investigate further as we have not been able to reproduce the issue? Titanium info Titanium config Titanium sdk
  4. Srdjan Lukic-Bardak 2014-03-11

    Ti log files.
  5. Srdjan Lukic-Bardak 2014-03-11

    Ritu I'm just uploadet 3 text files with log data as you requested. in titanium-info.txt i have removed all my profiles since I do have some client apps that are still not published.
  6. Ritu Agrawal 2014-03-11

    Make sense. Thanks for the information.
  7. Srdjan Lukic-Bardak 2014-03-11

    Hi Ritu I might have a usefull work around for it. It looks like the issue was simulator sdk was sat to 7.0.3 and I had no other options then that. So I used xCode to download iOS SDK 7 and 6.1 and when starting "Run Configurations" through TS I still only had 7.0.3. What worked for me was to download a older version of TS (Titanium Studio 3.1.3) from https://wiki.appcelerator.org/display/tis/Reverting+to+a+Previous+Version after overwriting my current version I was able to enter "Run Configurations" where I now have the option to select all installed iOS SDK's After setting SDK to 7.1 everything is working fine. I even updated my TS back to the latest version and everything still work. I'm not sure why this happend, but it looks like the sdk configurations section is not collecting the latest installed SDK's. cheers!
  8. Ritu Agrawal 2014-03-11

    Hmmm..interesting. Glad that things are working for you now.

JSON Source