Titanium JIRA Archive
Appcelerator Community (AC)

[AC-1697] OSX Yosemite - JVM Shared library does not contain the JNI_CreateJavaVM symbol

GitHub Issuen/a
Resolution Date2015-07-03T23:35:49.000+0000
Affected Version/sn/a
Fix Version/sn/a
LabelsTCSupportTriage, java, osx, studio3, yosemite
ReporterNicholas Thurston
AssigneeRadamantis Torres-Lechuga


Updated to OS X 10.10 public beta 3. Titanium studio will not start due to JVM Shared library does not contain the JNI_CreateJavaVM symbol. This was initially with Studio 3.3, tried to install the 3.4 RC and get the same error. Java version was originally 1.7 and didn't work. Updated to 1.8.0_40 and still not working.


  1. Praveen Innamuri 2014-09-18

    This error could be due to running Studio on wrong architecture of JVM. For example, you might be having 64-bit Studio and trying to run it on 32-bit JVM. Can you make sure the architecture of Studio and JVM are same ?
  2. Nicholas Thurston 2014-09-18

    How do I check architecture of Studio?
  3. Praveen Innamuri 2014-09-18

    You can find "arch" details at : About Titanium Studio > Installation Details > Configuration.
  4. Nicholas Thurston 2014-09-18

    It won't start though, so I can't do that. Is there a command I can run.. or a file somewhere that will tell me?
  5. Nicholas Thurston 2014-09-18

    Fixed by downloading this.. http://support.apple.com/kb/DL1572 Java -version still shows 1.8.0_40, but now it will load Studio.
  6. mustafa 2014-10-20

    Update java for OS X http://support.apple.com/kb/DL1572?viewlocale=en_US&locale=en_US found solution on stackoverflow
  7. Mauro Parra-Miranda 2014-10-28

    Hello [~nthurston]! Does this replicate with the latest Yosemite release? I tried this and Yosemite just installed the JDK 1.6 for compatibility and everything worked perfect. Best Regards
  8. Nicholas Thurston 2014-10-28

    With the full release of Yosemite, I still had to reinstall [this](http://support.apple.com/kb/DL1572?viewlocale=en_US&locale=en_US) to get studio to run.

JSON Source