Titanium JIRA Archive
Appcelerator Community (AC)

[AC-184] Can't install or update Cli

GitHub Issuen/a
ResolutionNot Our Bug
Resolution Date2015-07-21T20:35:12.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAppcelerator CLI
ReporterRobert Blom
AssigneeRadamantis Torres-Lechuga


After installing Appcelerator Studio (Where Cli failed to install), I can't install or update Cli. Cli should be available because I used Titanium studio before (Which still is installed on my machine). node -v gives v0.12.5 npm -v give 2.11.2 Attached is my error log.




  1. Amimul Hossain 2015-06-27

    Hello, You can install Appcelerator CLI through terminal. Please follow the link [here](https://web.appcelerator.com/product/cli). Follow the instruction there. Make sure you you have Node.js installed. Thanks.
  2. Robert Blom 2015-06-29

    Thanks for the link, but already tried this. The results are: sudo npm install appcelerator -g it ends with semver@3.0.1 I can't see any errors appc setup. -bash: appc: command not found. Kinds regards
  3. Amimul Hossain 2015-06-30

    Hello [~info7], Your problem is with your node.js. Please remove the current node.js and install the latest node.js from the link. After that again try following the instruction on the link. Make sure you have JDK properly updated. Reply with your findings. Thanks.
  4. Robert Blom 2015-06-30

    Hello Amimul Hossain, I uninstalled my version of node.js and installed the version from the link (0.10.37). JDK is up to date as far as I know (1.7.0). Still the same error: appc: command not found. In addition I tried the appcelerator studio installer. At the prerequisites screen it says Appcelerator Cli will be installed. After hitting next It says 'Installation of Appcelerator Cli failed with issues' . The more button says: Could not locate appc executable after installation. Thanks
  5. Amimul Hossain 2015-07-01

    Hello [~info7], what does the "sudo npm install appcelerator -g" command output? does it installed properly?
  6. Robert Blom 2015-07-01

    See screenshot !screenshot-1.png!
  7. Praveen Innamuri 2015-07-06

    Looks the npm prefix value is corrupted on the machine. - Run the command npm config get prefix and/or npm get prefix and make sure this refers to the default value /usr/local. - Also, env variable NPM_CONFIG_PREFIX should be empty.
  8. rafael guedes alves 2015-07-12

    Like Praveen said... npm config set prefix /usr/local Did solve the problem!
  9. Robert Blom 2015-07-13

    Like Praveen said setting the npm prefix to the default fixed my problem. Thanks guys for all the support.

JSON Source