Titanium JIRA Archive
Appcelerator Community (AC)

[AC-1964] Keyboard input is messed up on Xperia active (ST17i) (at least)

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2014-01-23T06:22:03.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsTitanium SDK & CLI
LabelsAndroid, textfield
ReporterKarl Nilsson
AssigneeRitu Agrawal



We have some users reporting problem when entering text in TextFields when using a Sony Xperia phone. The users have tried both with and without the T9 keyboard . Since we have not been able to find that phone to try on we have not been able to reproduce this issue. One user report goes like this "It seems to take only one letter per key. It is not possible to erase, change lines or use the suggested words." Another user report: "The first letter is correct but incorrect letters popup. The word suggestions are not accessible. It is also not possible to delete letters."

Test case

This goes for all textfields, no test case required.


See attached image (ok, not perfect image, but it is difficult to show this without creating a movie).




  1. Ritu Agrawal 2014-01-22

    [~karl.n] We tried to reproduce this issue on following two Sony Xperia devices but we have not been able to reproduce this issue. Please provide us a complete test case that reproduces this issue. 1.Sony Xperia LT26i 2.Sony Xperia ST25i We do not have access to a Sony Xperia ST17i device.
  2. Karl Nilsson 2014-01-29

    Ok, big thanks anyway for putting some effort into this!

JSON Source