Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2011] Adding a custom Titanium Module results Script Error = Couldn't find module (Tried all possible ways, No module resources to copy always)

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2013-05-01T18:19:33.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAppcelerator Modules, Titanium SDK & CLI
Labelsios, module
ReporterGeorge Taskos
AssigneeMauro Parra-Miranda



Screen Shot 2013-04-15 at 12.28.23 AM.png2013-04-14T21:30:46.000+0000216825
Screen Shot 2013-04-15 at 12.29.16 AM.png2013-04-14T21:30:46.000+0000249019


  1. George Taskos 2013-04-15

    Problem is the type of project I selected. It was the Single Window Applicatio Titanium Project type. I chose a tabbed project and it was perfectly worked!!!!
  2. Daniel Sefton 2013-05-01

    Hi George, That's odd. The project type shouldn't matter. Did you try cleaning the project etc. (Project -> Clean), making sure the correct Ti SDK is selected in tiapp.xml (preferably 3.1 GA), and checking the version of the SDK used to build the module? I tried creating a Single Window Application and then adding a custom module, and it loads as expected (Ti SDK 3.1 GA, Ti Studio, Xcode 4.5.2):
    module is => [object ComTestModule]
  3. Mauro Parra-Miranda 2013-11-22

    Tested, this works fine with latest Ti Studio

JSON Source