Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2030] Android: Cannot build Android projects for 3.1.1 SDK following 3.1.1 upgrade

GitHub Issuen/a
Resolution Date2013-06-20T17:09:10.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAppcelerator CLI, Studio, Titanium SDK & CLI
Labels3.1.1, android, sdk, studio, triage
ReporterMark Mokryn
AssigneeDaniel Sefton


*Steps to reproduce* 1. Standard upgrade per the popups - i.e. Studio 3.1.1, SDK 3.1.1, CLI 3.1.1, Alloy 1.1.3 2. File --> New --> Mobile Project --> Default Alloy/Default Classic 3. Create the project as above 4. set the SDK version in tiapp.xml to 3.1.1.GA 5. build for Android device. 6. The build fails immediately. *build.log*
Logfile initialized
[INFO] logfile = /Users/Marek/Documents/Titanium_Studio_Workspace/TiClassicTest/build.log
[DEBUG] /Users/Marek/Library/Application Support/Titanium/mobilesdk/osx/3.1.1.GA/android/builder.py install TiClassicTest /Users/Marek/ti-androidsdks /Users/Marek/Documents/Titanium_Studio_Workspace/TiClassicTest com.classic.test 3
*Note* When changing to 3.1.0.GA in tiapp.xml all is fine.




  1. Daniel Sefton 2013-06-18

    Hi Mark, Unfortunately I can't reproduce this with my setup. I followed your steps and it builds to an Android device without issue for me. Please could you attach your Studio log file and diagnostic? (Help -> Studio -> View Log File & Run Diagnostic Test...) P.S. If your log file happens to be really long, it might be better to clean it first, then reproduce the error, then attach that.
  2. Mark Mokryn 2013-06-18

    The Studio log is actually very short, after I deleted what was there previously: !ENTRY org.eclipse.osgi 2 1 2013-06-18 21:12:20.827 !MESSAGE NLS missing message: BasicProjectCreationPage_crossPlatformWarningAndroid in: com.appcelerator.titanium.ui.wizard.messages !ENTRY org.eclipse.osgi 2 1 2013-06-18 21:12:20.828 !MESSAGE NLS missing message: BasicProjectCreationPage_crossPlatformWarningIOS in: com.appcelerator.titanium.ui.wizard.messages
  3. Daniel Sefton 2013-06-18

    Hmm, what happens if you build for iOS? Does that work fine?
  4. Mark Mokryn 2013-06-18

    iOS builds work fine. BTW - it's not just for new projects. I just tried to build an existing project that builds fine with 3.1.0, and it fails in identical fashion, build.log essentially the same as in my initial report.
  5. Mark Mokryn 2013-06-20

    My bad...... Android SDK 10 was not installed - I had 8 as a minimum for previous SDKs. Installing SDK 10 fixed it. You can close this ticket, but I suggest that Studio shouldn't fail in such a cryptic manner if an SDK is missing. Thanks.
  6. Daniel Sefton 2013-06-20

    Ah, that's useful to know, thanks. Closing as fixed.

JSON Source