Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2075] When trying to run get error - Unable to locate the CLI executable. Please restart Studio or use Help > Check for Titanium Updates to install Titanium CLI.

GitHub Issuen/a
Resolution Date2013-11-11T20:59:08.000+0000
Affected Version/sn/a
Fix Version/sn/a
ReporterAndrew Sykes
AssigneeMauro Parra-Miranda


Steps to Reproduce

Since installing updates for Titanium Studio, I have been unable to run anything. I always get the above message. I have tried restarting Titanium studio checked for updates and there are none. I have tried doing a fresh download and install and I get the same results. There is probably something simple I need to do, but being ewn to Titanium and also being new to Apple I am struggling to make any sence of this.

Actual Result

error - Unable to locate the CLI executable. Please restart Studio or use Help > Check for Titanium Updates to install Titanium CLI.

Expected Result

Iphone simulator should lanuch with my app


titanium diagnostics.txt2013-11-07T21:18:51.000+000010536


  1. Eric Wieber 2013-11-08

    We have seen this issue before. Often this is due to Titanium not installing correctly because the 'prefix' is something other than "/usr/local". Please try the following terminal commands (comments are in {color:blue}blue{color}): $ npm get prefix {color:blue}(to check that your prefix is incorrect){color} $ npm set prefix /usr/local {color:blue}(set the prefix to what it should be){color} $ sudo npm install -g titanium {color:blue}(reinstall Titanium with the correct prefix){color} After that, please verify if you are able to run a simulator or let us know if the issue persists.
  2. Andrew Sykes 2013-11-09

  3. Eric Wieber 2013-11-11

    This looks to be a different, but related issue. From your logs, I can see that you are using node.js v0.10.x and Titanium SDK v3.0.2 for your project, but have up to Titanium SDK v3.1.3 installed. Please check your project's tiapp.xml to make sure that you are using SDK v3.1.3 in your build properties. If not, set your project to use SDK v3.1.3, as v3.0.2 is incompatible with node.js v0.10.x. If that does not work, you should be able to force the latest Titanium SDK (v3.1.3) to be your default with this command: $ titanium sdk install --force --default Please verify if the above allows you to run the simulator.
  4. Andrew Sykes 2013-11-11

    Eric Thanks for the update. I needed to do the $ titanium sdk install --force --default command first then go through my projects and update the SDK to v3.1.3. After that I have now managed to get the simulator up and running thanks for your help, this is all starting to make a lot more sense Andy
  5. Eric Wieber 2013-11-11

    Good to hear; glad to help.
  6. Mauro Parra-Miranda 2013-11-21

    Solved in the user's end with SupportTeam help.

JSON Source