Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2114] Unable to select correct provisioning profile

GitHub Issuen/a
Resolution Date2014-01-12T19:04:24.000+0000
Affected Version/sn/a
Fix Version/sn/a
ReporterMichael Stelly
AssigneeRitu Agrawal


Steps to Reproduce

Select ad-hoc distribution Select 'Select Provisioning Profile' I've tried all steps associated with ticket TC-1616 and from Forum Post http://developer.appcelerator.com/question/145816/unable-to-select-provisioning-profile-when-building-to-ios-device#comment-198747. Nothing has worked. I am not able to upgrade to 3.2 yet. I need a fix for 3.1.3.GA or at least a workaround.

Actual Result

Required Provisioning Profile not available in the select list

Expected Result

Required profile available and selectable in select list.




  1. Ritu Agrawal 2014-01-10

    I would appreciate if you can execute the following command and attach the output to this ticket as it will help us narrow down the issue. ti info –t ios
  2. Michael Stelly 2014-01-11

  3. Ritu Agrawal 2014-01-12

    Thank you for providing the requested information. The output shows that you have no distribution profile but 3 adhoc provisioning profiles. Next step would be to determine if these profiles are valid. I would appreciate if you can try building the project from the command line using the following command and see if it succeeds. It would help us isolate the problem to Studio or profile.

    Go to the project directory on command line (cd to <workspace_path>\myiOSApp)

    "/usr/local/bin/titanium" "--no-colors" "--no-progress-bars" "--no-prompt" "--no-banner" "build" "--platform" "ios" "--sdk" "3.2.0.GA" "--build-type" "production" "--log-level" "trace" "--project-dir" "<workspace_path>\myiOSApp" "--distribution-name" "<distribution certificate name>" "--ios-version" "7.0.3" "--keychain" "" "--pp-uuid" "<distribution provisioning profile UUID>" "--target" "dist-appstore"

  4. Michael Stelly 2014-01-12

    Thanks for walking me through this. Apparently, I got confused about which profile went with which project. I did not have a distro provision for my app, just a dev one. I went to the Apple Dev site, created the distro provision and got everything working. Your help was invaluable. Thank you. Please close the ticket.
  5. Ritu Agrawal 2014-01-12

    Closing this ticket based on reporter's confirmation.

JSON Source