Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2411] Android: Error when trying to run sample on Fedora Linux

GitHub Issuen/a
ResolutionNeeds more info
Resolution Date2013-08-27T18:26:01.000+0000
Affected Version/sn/a
Fix Version/sn/a
AssigneeMauro Parra-Miranda


When I try to run a sample program, it's showing the following error:
[ERROR] Exception occured while building Android project:
[ERROR] Traceback (most recent call last):
[ERROR]   File "/root/.titanium/mobilesdk/linux/3.1.2.GA/android/builder.py", line 2596, in <module>
[ERROR]     builder.build_and_run(False, avd_id, debugger_host=debugger_host, profiler_host=profiler_host)
[ERROR]   File "/root/.titanium/mobilesdk/linux/3.1.2.GA/android/builder.py", line 2400, in build_and_run
[ERROR]     launched, launch_failed = self.package_and_deploy()
[ERROR]   File "/root/.titanium/mobilesdk/linux/3.1.2.GA/android/builder.py", line 1881, in package_and_deploy
[ERROR]     self.keystore_alias], protect_arg_positions=(6,))
[ERROR]   File "/root/.titanium/mobilesdk/linux/3.1.2.GA/android/run.py", line 45, in run
[ERROR]     process = subprocess.Popen(args, stderr=subprocess.PIPE, stdout=subprocess.PIPE)
[ERROR]   File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
[ERROR]     errread, errwrite)
[ERROR]   File "/usr/lib/python2.7/subprocess.py", line 1249, in _execute_child
[ERROR]     raise child_exception
[ERROR] OSError: [Errno 2] No such file or directory
[ERROR] :  Build process exited with code 1
[ERROR] :  Project failed to build after 29s 938ms
[ERROR] Application Installer abnormal process termination. Process exit value was 1


  1. Daniel Sefton 2013-08-27

    Hi Gowtham, Please attach your Studio log file and diagnostic: - Help -> Studio -> View Log File - Help -> Studio -> Run Diagnostic Test... Also, have you made sure to install the Android SDKs through the SDK manager? (Run "android" in terminal) - API 8 and 10 are important Finally, which sample are you trying to run? e.g. a new Default Classic Project? Thanks!
  2. Gowtham 2013-11-23

    Its solved and its because of openjdk version and when I changed to oracle jdk. Problem gets solved. Thank you Daniel and Maura.

JSON Source