Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2492] iOS: RangeError: Maximum call stack size exceeded when running simulator

GitHub Issuen/a
Resolution Date2013-04-01T16:49:05.000+0000
Affected Version/sn/a
Fix Version/sn/a
Labelsregression, triage
ReporterVic Agu
AssigneeDaniel Sefton


Steps to Reproduce

On Mac 10.8.2, I installed titanium with 2 different sdks (3.0.2, 3.0.0) and whenever I try to run anything on the iphone simulator, even the sample files, I get an error. EDIT: I just tried 2.1.4 again and it worked this time.

Actual Result

The error is: /usr/local/lib/node_modules/titanium/node_modules/longjohn/index.js:114 throw e; ^ RangeError: Maximum call stack size exceeded

Expected Result

Programs should run in simulator.




  1. Daniel Sefton 2013-03-21

    Hi Vic, Does this happen for all the Studio template projects like "Default Project", and "Default Alloy Project" too? Is this a runtime, or build-time error? Cheers.
  2. Eric Merriman 2013-03-21

    Hello Vic, The CLI (Command line interface) uses commands for things like "build" and "clean" that come from the SDK. Which SDK it uses for this purpose is set by the command "ti sdk select". To use the commands from 3.0.2.GA for example, you set "ti sdk select 3.0.0.GA". To see the setting you currently have, you can simply enter "ti sdk" in the terminal, and you should see the SDK set as "active". I recommend you set this to 3.0.2.GA in your case. This is different than the SDK used to compile, which is set in the project's Tiapp.xml. While these could be different, it's a good idea to keep them in sync when possible. Could you report the version of npm and node you are running? "npm -v" and 'node -v" in the terminal? Thanks.
  3. geoff 2013-03-21

    Hi Eric, I'm having the same issue. I tried the latest nightly and updated node to 0.9.0 npm is 1.1.44 I'm about re-download 3.0.2 studio and re-install it. Daniel, I have managed to get the simulator with work via CLI but I cannot publish an iOS app via titanium studio nor the CLI. It looks like a build time error.
  4. Vic Agu 2013-03-22

    @Daniel Yes it happens for those templates as well. It might be a build time error, I'm not sure. @Eric I'll try that. Also npm version is 1.2.14 and node is v0.10.0
  5. André Perazzi 2013-03-25

    I'm having the same problem... sdks (3.0.2, 3.0.0) Npm v. 1.2.14 Node v. v0.10.0 Titanium Studio, build: CLI version 3.0.24 --------------------- Fixed the problem installing an older version of Node: v0.8.17
  6. geoff 2013-03-25

    I fixed my issue, somehow the project itself was corrupted. @Vic and @Andre You need to uninstall your node.js You are using version 0.10.0 which is not supported. I recommend downloading version 0.8.17. Here is a link to that version: http://nodejs.org/dist/v0.8.17/
  7. Vic Agu 2013-03-26

    @geoff that fixed it. Thanks!
  8. Daniel Sefton 2013-04-01

    I'm going to assume that installing the supported version of node.js is the fix for this issue. Resolving.
  9. André Perazzi 2013-04-01

    It fixes.
  10. Sergio Infante Montero 2013-09-02

    I have the same issue with iOS simulator, and I have v0.8.17 version for node. The problem is not solved

JSON Source