Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2585] Longjohn error on 3 separate machines when building with 3.2.1.GA

GitHub Issuen/a
Resolution Date2014-04-11T21:56:48.000+0000
Affected Version/sn/a
Fix Version/sn/a
Labels3.2.1, CLI, Titanium, longjohn.js
ReporterJeff "Huey" Huelsbeck
AssigneeChris Barber


I cannot get any projects to build under Titanium SDK 3.2.1.GA. I updated 3 separate systems and I can't build out a project in TitaniumStudio or the Titanium CLI on any of them. My preferred method for the past year has been the CLI. All attempts are returning the exact same error: ti build /usr/local/lib/node_modules/titanium/node_modules/longjohn/dist/longjohn.js:184 throw e; ^ [object Object] I've tried building current projects that work fine in 3.1.3.GA. I've tried creating brand new projects (which works fine) and then building them, same error. I've run through the setup to make sure everything was filled out and get the error when selecting Check Environment or iOS settings. I don't ever get more robust errors like I've seen in other tickets, it's always ended with [object Object] and no details about what's throwing the error exactly. If I switch my default SDK back to 3.1.3 and change it in tiapp.xml back to 3.1.3 everything works fine. I am running ti CLI on 3 different machines all with exactly the same issue, so I must have something setup wrong on all 3 machines. I've dug in a little deeper and if I type 'ti -v' at the command prompt I get back 3.2.1, and if I type 'which ti' I get back /usr/local/bin/ti. Now if I type 'ls -la /usr/local/bin/ti' I get back: lrwxr-xr-x 1 root admin 41 Feb 19 01:11 /usr/local/bin/ti -> ../lib/node_modules/titanium/bin/titanium And finally if I type in '/usr/lib/node_modules/titanium/bin/titanium -v' I get back 3.1.2, which makes absolutely no sense to me. Why would 'ti -v' give me 3.2.1 but when I use the full path to where the 'ti' command is linked it gives me back 3.1.2? I must have messed something up along the way but I'm not necessarily sure how it relates to the longjohn error I'm seeing and what I need to do to fix it. I've uninstalled and reinstalled the titanium cli through npm several times and haven't seen changes in any of the behavior above.


  1. Ritu Agrawal 2014-02-19

    Can you please attach the output of the following command: 1. ti info 2. ti config 3. ti sdk 4. npm list -g titanium
  2. Jeff "Huey" Huelsbeck 2014-02-20

  3. Jeff "Huey" Huelsbeck 2014-02-21

  4. Ritu Agrawal 2014-02-22

    Do you have Geny Motion emulator installed on this machine?
  5. Jeff "Huey" Huelsbeck 2014-02-23

    I installed it after I started getting this error because a Google search suggested that it might be the cause for the issue. It's the same issue before and after installation.
  6. Jeff "Huey" Huelsbeck 2014-02-23

    I don't know if this helps, but if I run ti setup and then select either 2) check or 8) ios I get the error, but everything else seems to work as expected.
  7. Jeff "Huey" Huelsbeck 2014-02-23

    And I have installed Genymotion and have installed the Moto X 4.4.2 Virtual Device. I also ran: ti config genymotion.enabled true per the instructions found here: http://www.appcelerator.com/blog/2013/12/using-genymotion-with-titanium-3-2/ Same issue before I ran the ti config command and after, I don't know if there is anything else I need to do to get Genymotion working correctly.
  8. Ritu Agrawal 2014-02-24

    This issue is likely to be related to Geny Motion emulator. Is it possible to remove Geny Motion emulator completely from this machine and see if you still run into this issue? Please let us also know if it is a Windows or OSX machine. I understand that you had mentioned Maverics earlier but I just want to confirm that since you are using multiple machines.
  9. Jeff "Huey" Huelsbeck 2014-02-24

    Well I removed genymotion and genymotion shell apps but I"m still getting the same error. Do I need to remove the ti config for genymotion? How do I do that? All 3 machines are OSX, but I'm only having issues on the one machine now. Is there a faster process I can use? This is taking a large amount of time with the back and forth. I have a paid account, is there a number I can call to talk to somebody about this to help resolve it faster?
  10. Ritu Agrawal 2014-02-24

    I am glad you brought it up. There is a direct help desk line for the paid accounts and it would be much better to pursue this case there. I am assigning this ticket to the person who leads help desk efforts and would assist you further.
  11. Jeff "Huey" Huelsbeck 2014-02-24

    Great! Thanks for the help!
  12. Jeff "Huey" Huelsbeck 2014-03-14

    I upgraded to 3.2.2.GA and I'm still having this issue. What number can I call to try and resolve this over the phone?
  13. Chris Barber 2014-03-27

    It's possible that the Titanium CLI config file has become corrupt or missing some required settings. Please do the following:
        mv ~/.titanium/config.json ~/.titanium/config.json.orig
        ti setup quick
  14. Chris Barber 2014-04-11

    The cause was a iPhone distribution cert that node-forge was unable to parse. I've created a separate ticket to improve error handling when this situation arises.

JSON Source