Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2652] CLI 3.0: Titanium build for android cannot detect the Android SDK targets even when they are available

GitHub Issuen/a
Resolution Date2013-01-28T19:23:28.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsTitanium SDK & CLI
ReporterMukul Sharma
AssigneeVarun Joshi


Steps to Reproduce: 1. Create an application 2. Run "titanium build" 3. type "android" Actual: [ERROR] Unable to detect Android SDK targets. Please download SDK targets via Android SDK Manager and try again. (version 2.2 or newer) Expected: To build the android application


  1. Varun Joshi 2013-01-26

    Hi Mukul, Can you please provide the error log and the error that you are getting (probably a screenshot if possible)? Also, please post the exact commands you are typing in the terminal. Thanks, Varun
  2. Mukul Sharma 2013-01-27

    Hi Varun, This issue has been resolved. I should've commented earlier and closed it but apologies for that. The requirement here is that ANDROID_SDK and ANDROID_NDK environment variables must be set before Titanium Android build will work. I believe because of legacy support, python scripts still rely on the ANDROID_SDK and ANDROID_NDK values. If you can improve the documentation, that would be great. Thanks, Mukul
  3. Varun Joshi 2013-01-28

    Hi Mukul, I am glad it worked for you. Just a quick tip, if you run the command "titanium setup" command before running any other commands, it would take care of the general pre-configuration you need to have to begin using CLI. Thanks, Varun
  4. Mukul Sharma 2013-01-28

    You are absolutely right Varun. Just tried it out. 'ti setup' works like a charm. Should've done that in the first place. Thank you very much!! Mukul

JSON Source