Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2722] in Titanium Studio, build: when I create a 2.1.4 module apps cannot find the module

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2013-05-31T19:22:47.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAppcelerator Modules, Studio
ReporterJim Young
AssigneeMauro Parra-Miranda


I create a module in Titanium Studio, build: for 2.1.4 and when I include it in an ios project I get the following: [WARN] Could not find Titanium Module id: org.xxx.av3titanium214, version: 3.0, platform: iphone [ERROR] Could not find the following required iOS modules: [ERROR] id: org.xxx.av3titanium214 version: 3.0 [ERROR] Error: Traceback (most recent call last): File "/Library/Application Support/Titanium/mobilesdk/osx/2.1.4.GA/iphone/builder.py", line 771, in main exit(1) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site.py", line 364, in call raise SystemExit(code) SystemExit: 1 The module is in: /Library/Application Support/Titanium/modules/iphone/org.xxx.av3titanium214/3.0 If I create a 3.1 module it works fine.


  1. Carter Lathrop 2013-05-31

    Jim, I was unable to reproduce this bug. Can you please provide a sample module that one can test on 2.1.4GA and also on 3.1GA to show the disparity. Also it would be helpful to provide a list of steps to reproduce and expected behavior vs actual behavior as outlined here: https://wiki.appcelerator.org/display/guides/How+to+Submit+a+Bug+Report Marking as cannot reproduce until more information provided. Thanks, Carter
  2. Jim Young 2013-06-05

    More Specifically: I created a new module setting the SDk to 2.1.4 Built it and added it to my system, did not modify it at all! Created a new mobile project setting SDK to 2.1.4 and copied the lines from the example app.js to require the module and print it out to my new mobile project. // TODO: write your module tests here var wtf214 = require('org.myactions.wtf214'); Ti.API.info("module is => " + wtf214); I added the module to the Modules area of tiApp.xml and got the following when I tried to run the simulator: [INFO] One moment, building ... [INFO] Detected third-party module: org.myactions.wtf214/0.1 [INFO] Detected third-party module: org.myactions.wtf214/0.1 [INFO] Titanium SDK version: 2.1.4 (11/09/12 12:46 51f2c64) [INFO] iPhone Device family: universal [INFO] iPhone SDK version: 6.1 [INFO] iPhone simulated device: iphone [INFO] Minimum iOS version: 4.3 Linked iOS Version 6.1 [INFO] Compiling localization files [INFO] Launching application in Simulator [INFO] Launched application in Simulator (16.26 seconds) [INFO] Application started [INFO] wtf214proj/1.0 (2.1.4.GA.51f2c64) [ERROR] Script Error = Couldn't find module: org.myactions.wtf214. So I gave up and tried it using SDK 3.0.0 and it could find the module. Hope this helps. Jim Young
  3. Mauro Parra-Miranda 2013-11-24

    Working in latest GA.

JSON Source