Titanium JIRA Archive
Appcelerator Community (AC)

[AC-314] AppceleratorStudio: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.4 instead of 10.10.4. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2015-11-11T05:19:28.000+0000
Affected Version/sn/a
Fix Version/sn/a
ReporterAlberto Marcone
AssigneeShak Hossain


Sometimes, not sure how exactly to reproduce it, Studio would crash and not reopen with the error from the title. In order to fix it I tried: Deleting the Library/Saved Application State/com.appcelerator.studio (or whatever that folder is called): it worked once. Re-installing Appcelerator Studio from scratch: utterly frustrating, I can't reinstall every day the software. How can this be fixed?


  1. Papia Chowdhury 2015-09-18

    Hello, Couldn't reproduce this issue. Please try to update to the latest build of the Studio. If you continue to get this error, please let us know the environment details so that we can try to reproduce it. *Testing Environment:* Appcelerator Studio, build: Appcelerator Command-Line Interface, version 5.0.0-50 OS X version: 10.9.5 *Steps to test* 1. Create a simple project. 2. Run the project. *Result:* Project ran successfully without any warning and Studio didn't crash. Thanks.

JSON Source