Titanium JIRA Archive
Appcelerator Community (AC)

[AC-5651] Can build app with Studio but CLI fails

GitHub Issuen/a
ResolutionNeeds more info
Resolution Date2018-03-20T09:01:31.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAppcelerator CLI, Studio
Reportereric harms
AssigneeShak Hossain


Hello, Im trying to run an android app to a device and simulator via the cli, but the build is failing with [ERROR] Failed to run dexer: [ERROR] [ERROR] I can build the app to the device and simulator ok using Studio, but not cli. Ive attached my log files for the successful and failed builds, as well as my ti config and android ti info. I noticed in the the build logs, the build commands are different between studio and cli, but if I use the Studio build command in terminal, I get the same failure. my cli build command is appc run -p android -T device -C "FA6920317145" Ive tried Android API 25 and 26, as well as build tools 25 and 26. All my Android SDKs are updated, please see screenshot. If someone could please review my attached build logs and let me know if something sticks out, I would appreciate it, I'm stumped. Thanks, Eric




  1. Sharif AbuDarda 2018-03-09

    Hello, Is this started to happen on 7.0.2.GA? Are you able to build for Android in the previous SDK? Make sure you are not under a firewall by the connection provider or behind a smart switch that blocks certain URLs? Let us know by a trace log "appc run -p android -l trace". Thanks.
  2. eric harms 2018-03-09

    Hi Sharif, cli-trace.txt attached. ive only tried this with 7.0.2, ill try something lower. we're having a stripe module built and this is a simple test app. if i remove the module it works fine. but again whats troubling me is that i can run the app fine with Studio, but with the cli it breaks. Thanks
  3. eric harms 2018-03-09

    ok so im seeing now we built this module for 7.0.2 so i cant run the build at a lower sdk level. ill have to ask my contractor to do so. Thanks
  4. eric harms 2018-03-09

    but please let me know if you see anything in the logs. i feel like something in my cli isnt set up correctly.
  5. Mostafizur Rahman 2018-03-11

    [~eric.harms@gmail.com], Thanks for your feedback. Can you please share a simple test case to reproduce the issue on our end?
  6. eric harms 2018-03-12

    Hi, unfortunately i believe something in the module we are building is not playing well with the cli. Is there not a way we can get more information on what is actually failling? is there anything in the trace log that I posted that might shed some light? Thanks
  7. eric harms 2018-03-12

    if there is a way I can upload the sample project without it being public, Id be happy to provide you guys the code so you can run it on your end, please let me know. Thanks
  8. Sharif AbuDarda 2018-03-12

    Hello, You can send the sample project through our email, And we will test it. Let us know when you do. Thanks.
  9. Mostafizur Rahman 2018-03-18

 Just passing a followup here.Are you able to get that sorted out? Please send your sample project so that we can test it on our end. Please let us know if you need more help with this issue. Regards
 Axway Appcelerator Support
  10. eric harms 2018-03-20

    Hi Mastafizur, My apologies I did not get back to you sooner, Id still like you guys to take a look at the code. Can you provide me the email I should use? Ill provide dropbox links for you to download the code. Thanks

JSON Source