Titanium JIRA Archive
Appcelerator Community (AC)

[AC-5779] iOS: Assets folder is not loading in Xcode build

GitHub Issuen/a
Resolution Date2018-07-07T20:05:11.000+0000
Affected Version/sn/a
Fix Version/sn/a
LabelsAssets,, Xcode
ReporterPankti Pancholi
AssigneeShak Hossain


Our application is up and running in App Stores, everything is working fine with appcelerator studio but when I have archived build in Xcode to test with tesflight it is not loading assets Images.


  1. Mostafizur Rahman 2018-06-26

    Hello, Thanks for reaching out to us. Can you please explain more exactly when you get this issue?  It would be better if you can share a screenshot which displays the issue.
  2. Hans Knöchel 2018-06-26

    [~ppancholi] Opening generated app projects in Xcode is not recommended and requires additional setup to package assets properly. If you are getting this behavior when using the CLI to package your app for the store (e.g. appc run -p ios -T dist-appstore or via Studio > Distribution), it could indeed by an SDK issue, but there are no known issues for that. Please let us also know your environment to be able to check on that specific version. Thank you!
  3. Pankti Pancholi 2018-06-26

    I am getting this issue when I generate build for the app from Xcode and upload it on TestFlight. So, when I run TestFlight version of my app it is not loading any images, fonts or most off the things which are in assets folder. Appcelerator CLI : version 7.0.4 Titanium SDK : 7.2.0 Xcode: 9.4 Axway Appcelerator Studio, build:
  4. Hans Knöchel 2018-06-26

    Yep, that is not supported by the SDK. Builds should be packaged by the official tooling (see above). To do it manually, you need to take care of the resources manually, e.g. by dragging and linking them to your Xcode project.
  5. Pankti Pancholi 2018-06-26

    Everything is working fine on Simulator but when I run in device or generate build through Xcode these errors are coming.
  6. Pankti Pancholi 2018-07-03

    I have followed the steps given by appcelerator docs, It allows me to create adhoc ipa successfully. Everything is working good in App with adhoc certificate, I have created App Store distribution certificate now when I am trying to upload in itunestore from Appcelerator studio, after I finish build process it opens Xcode archive and When I click on archive I can not find any verify option that ask me to open login into iTunes Store as per mentioned in docs, I assume it is validation when I do validation it is allowing me to validate but not allowing me to upload in iTunes Store. Am I missing any steps? I have to update new version of app which is already there in iTunes Store but I am not able to upload and can't find any build in testflight as well as on iTunes Store. Thank You
  7. Hans Knöchel 2018-07-07

    Ad-Hoc builds cannot be pushed to the App Store, that's what Store builds are for. This is an Apple / Xcode process which we are following. They can be pushed to iTunes Connect though, which you are probably aiming to do. Once your build is inside the Xcode organizer, you can follow any native guide to upload it to iTunes Connect as well. You can learn the basic [here](https://developer.apple.com/support/app-store-connect/).

JSON Source