Titanium JIRA Archive
Appcelerator Community (AC)

[AC-587] Technical issues due to 5.1.2.GA upgrade has broken compilation

GitHub Issuen/a
ResolutionNot Our Bug
Resolution Date2016-01-29T13:53:54.000+0000
Affected Version/sAppcelerator Studio 4.4.0
Fix Version/sn/a
ComponentsAppcelerator CLI
ReporterRainer Schleevoigt
AssigneeShak Hossain


After installing of SDK 5.1.2.GA the compilation stopps with [DEBUG] : Copying template /Users/fuerst/Library/Application Support/Titanium/mobilesdk/osx/5.1.1.GA/android/templates/build/AppInfo.java => /Users/fuerst/Documents/APPC_WORKSPACE/Tierstimmenarchiv/build/android/gen/de/appwerft/tierstimmenarchiv/TierstimmenarchivAppInfo.java 2016-01-28T12:11:29.634Z | TRACE | titanium exited with exit code 0 2016-01-28T12:11:29.635Z | TRACE | Sending exit signal to titanium process: 2831 After this I have started tools/android and upgraded all new stuff. Output of appc ti config: https://gist.github.com/AppWerft/4af36849f0b6eff4ba2c Output of appc ti. info -t android https://gist.github.com/AppWerft/9ec70cacc2d337beaa06 check gives me: https://gist.github.com/AppWerft/4a6b96a8731b149f7309 This I see weired: Titanium SDK ✓ latest sdk installed (v4.0.0.GA) ✓ selected sdk up-to-date (v4.0.0.GA)


  1. Rainer Schleevoigt 2016-01-29

    Self solved: The issue wasn't in relation to upgrade. I found invalid text (utf8) inside description tag in tiapp.xml. Hint for me was the last valid command COPY AppInfo.java. After editing the tiapp.xml the problem was solved. Please close.
  2. Hans Knöchel 2016-01-29

    Danke Rainer!
  3. Rainer Schleevoigt 2016-01-29

    I think it is a good idea to catch this kind of parse errors in tiapp.xml. Wrong characters kills the script.

JSON Source