Titanium JIRA Archive
Appcelerator Community (AC)

[AC-860] Not able to launch IOS 7.1 simulator when xcode 6.2 is installed

GitHub Issuen/a
Resolution Date2015-09-29T16:36:54.000+0000
Affected Version/sn/a
Fix Version/sn/a
Labelsios7.1, xcode6.2
ReporterThomas Neerup
AssigneeShak Hossain


Steps to Reproduce

Install xcode 6.2 Check if 7.1 simulator is installed Run a simple Titanium app in IOS 7.1 simulator

Actual Result

[Error]: Invalid '--sim-version' value '7.1' 8.2

Expected Result

Run the app in simulator




  1. Shuo Liang 2015-03-24

    Hi, There are some suggestation you may try: 1. Make sure you have IOS 7 SDK installed in Xcode. 2. To go run configuration in studio, delete the setting file corresponding to your project. 3. Clean the project, include delete the build folder in you project directory. 4. Run your app again with latest Ti SDK, see if it happen again. Regards, Shuo
  2. Thomas Neerup 2015-03-24

    Hi Shou... I Tried all of Your suggestions, but nothing sems to work... I event tried reinstalling Xcode. In my Run configuration i'm not able to select Simulator Version other than 8.2 Any suggestions? *ti info* gives: ..... *Xcode* 6.2 (build 6C131e) - Xcode default Install Location = /Applications/Xcode.app/Contents/Developer iOS SDKs = 8.2 iOS Simulators = 8.2 Supported by TiSDK 3.5.1.GA = yes .... *iOS Simulators* 8.2 iPhone 4s (iphone) UDID = CD02BF69-873B-478A-A451-D0428F36D248 iPhone 5 (iphone) ... 8.1 iPhone 4s (iphone) UDID = CCBD8896-F28B-4438-9F43-328E26BA2DFA .... 7.1 iPhone 4s (iphone) UDID = 3561B412-42F3-420A-93F6-5CACB1DDC699 iPhone 5 (iphone) UDID = 68EC3659-BDA4-4279-AD07-54519AC9B1A6 iPhone 5s (iphone) UDID = 5D50D258-DB0F-48A7-AE2A-24BBCCA43FF6 iPad 2 (ipad) UDID = 40319CA7-0F82-40B1-B0B2-74D0354A11D4 iPad Retina (ipad) UDID = 256FA3AD-5BD9-41E0-A660-6C753D3BA4DE iPad Air (ipad) UDID = 9D4387E9-528C-4BE0-9CD5-4BA49986B403
  3. Amimul Hossain 2015-08-29

    Use Appcelerator studio as Titanium is obsolete. Follow the instruction [here](https://web.appcelerator.com/product/studio) to download the latest Appcelerator studio. Now, follow the instruction [here](https://web.appcelerator.com/product/cli) to install CLI, SDK. Also, Make sure you have IOS 7 SDK installed in Xcode and download iOS 7.1 simulator from Xcode/preference/downloads/iOS 7.1 simulator. Hope this helps. Thanks.

JSON Source