Titanium JIRA Archive
Appcelerator Community (AC)

[AC-871] Failed to run Dexer - android

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2014-04-17T05:24:14.000+0000
Affected Version/sn/a
Fix Version/sn/a
Reportersarbari mukherjee
AssigneeRitu Agrawal


I am developing an application in titanium 3.2 to work in both IOS and Android. I am testing the application currently in Android 4.1 Note Tablet. Sometimes there is problem in creating the android apk. It shows the error [ERROR] : Failed to run dexer: [ERROR] Application Installer abnormal process termination. Process exit value was 1 Even if I clean build the project, restart the windows, even kill any adb or node.exe, still I get the same error. If I leave my machine idle for sometime, then again it starts working.


  1. Ritu Agrawal 2014-03-26

    Can you please provide the complete error output from Studio window to diagnose this issue further? Let us know Studio and SDK version as well.
  2. sarbari mukherjee 2014-03-27

  3. Ritu Agrawal 2014-03-27

    It is most likely a duplicate of TIMODOPEN-311 and related to ti.paint module. Can you please try Ti.paint 2.0.2 module as suggested in that ticket and let us know if it helps solve the issue?
  4. sarbari mukherjee 2014-03-31

    Hi..I faced the same problem even in other projects which do not use any module or widget. So this problem is not related to Ti.paint module.
  5. Ritu Agrawal 2014-04-06

    Please provide a simple project and complete environment information to reproduce this issue. We have tried several projects and we have not been able to reproduce this issue even a single time.
  6. Robin Williams 2014-07-22

  7. chanakya 2015-09-12

    Hi All, I install appcelerator studio in windows7. When run the application on emulator I am getting same error. Can any help out, how to resolve the issue. *Environments in windows os:* Operating System = Microsoft Windows 7 Ultimate Node.js = 0.10.13 npm Version = 1.3.2 Titanium CLI = 4.0.1 Appcelerator Studio = 4.1.1 Titanium SDK = 4.1.0.GA java = jdk1.8.0_51

JSON Source