[AC-1212] Not able to install Titanium Studio in My Mac.

GitHub Issuen/a
Resolution Date2015-09-15T03:47:10.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAlloy, Studio, Titanium SDK & CLI
Labelsalloy, alloy-cli, alloy-configuration, titanium
AssigneeShak Hossain


Hi Team, I am trying to install the Titanium Studio, Earlier it was working fine when i installed for for first time, But later got some issue in the work space and then when i tried to create new work space the new issues raised, like i am getting the message iOS SDK and Andriod SDK are not Configured but not able to do that, I unstall multiple times and installed back. when i am trying to get the version of titanium also i am getting problem, like if i give "which titanium" it is showing below. /usr/local/bin/titanium But when trying to get the titiinum version i am getting fatal error. titanium -v or titanium version I am getting following error FATAL ERROR: Error: Unable to parse config file. I tired sudo also but no use, According to some blogs i tried sudo npm install -g https://github.com/appcelerator/titanium.git But i am getting below error npm ERR! not a package /tmp/npm-4048-6ZkblFmi/github.com/appcelerator/titanium.git npm ERR! Error: ENOENT, open '/tmp/npm-4048-6ZkblFmi/github.com/appcelerator/titanium.git-unpack/package.json' npm ERR! If you need help, you may report this *entire* log, npm ERR! including the npm and node versions, at: npm ERR! <http://github.com/npm/npm/issues> npm ERR! System Darwin 12.5.0 npm ERR! command "node" "/usr/bin/npm" "install" "-g" "https://github.com/appcelerator/titanium.git" npm ERR! cwd /Users/kiranmantana npm ERR! node -v v0.10.30 npm ERR! npm -v 1.4.21 npm ERR! path /tmp/npm-4048-6ZkblFmi/github.com/appcelerator/titanium.git-unpack/package.json npm ERR! code ENOENT npm ERR! errno 34 npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /Users/kiranmantana/npm-debug.log npm ERR! not ok code 0 I am not unable find what is the issue, Was trying for last two days. I am attaching the debug.log




  1. Praveen Innamuri 2014-08-05 You are seeing the issue described at TIMOB-17346. It is likely that your config.json file is corrupted and you need to modify to make sure that is a readable JSON format.
  2. Praveen Innamuri 2014-08-05 Between, can you provide the diagnostic output (Help > Studio > Run Diagnostic Test...) ?

JSON Source