[AC-2135] Brand new install - [ERROR] : TypeError: Arguments to path.join must be strings

GitHub Issuen/a
Resolution Date2013-06-05T22:49:02.000+0000
Affected Version/sn/a
Fix Version/sn/a
ReporterChris Kline
AssigneeMauro Parra-Miranda



Screen Shot 2013-06-05 at 9.02.11 AM.png2013-06-05T16:03:15.000+000055169


  1. Chris Kline 2013-06-05 Just tried an uninstall and reinstall. When Titanium first fires up, it appears stuck at 30% "Initializing Node.ACS" Will not close cleanly -- I have to force quit.
  2. Chris Kline 2013-06-05 Stuck loading Node.ACS
  3. Daniel Sefton 2013-06-05 Hi Chris, There appears to be a problem with Node v0.10.6 and Titanium. Version 0.8 will work out of the box. According to one of our engineers, TIMOB-13549 should fix the issue. You might want to try Ti SDK 3.1.1 CI which can be downloaded from here: http://builds.appcelerator.com.s3.amazonaws.com/index.html#3_1_X Let me know if you need further help with this.
  4. Chris Kline 2013-06-05 Thanks, I can at least build a project now. 2 problems remain, but may just be annoyances: Titanium Studio still gets stuck at 30% 'Initializing Node.ACS' (below it says 'Logging into Node.ACS). It also keep telling me that updates are available (to 3.1.0GA). I shouldn't update, correct?
  5. Daniel Sefton 2013-06-05 For the 30% problem - I found a related issue here TISTUD-4322. You might want to double check the node version by running "node -v" in terminal. I asked for more explanation about the resolution in TISTUD-4322.
  6. Daniel Sefton 2013-06-05 For the updates, I'm not sure - you updated already right? Perhaps try again to see if it goes away?
  7. Chris Kline 2013-06-05 I updated to 'Ti SDK 3.1.1' like you instructed, but titanium wants to update. Is it safe to do the update that Titanium is asking me to do?
  8. Daniel Sefton 2013-06-05 Ah I see. Hmm. It should be ok. Before you do so you could head to:
    ~/Library/Application Support/Titanium/mobilesdk/osx
    Then try updating and see if the SDK folders are still in tact. But I don't think a 3.1 GA update will affect the 3.1.1 folder.
  9. Chris Kline 2013-06-05 Got it. Thanks!
  10. tom quas 2013-06-07
  11. Daniel Sefton 2013-06-07 You need node.js 0.8 :-)
  12. Mauro Parra-Miranda 2013-11-21 Solved by the user with SupportTeam's help.

JSON Source