[AC-2224] get build error & cannot update titanium

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2013-09-17T23:52:49.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsTitanium SDK & CLI
ReporterAngela King
AssigneeRitu Agrawal


I have installed titanium on the iMac. When I try to use the iPhone simulator I get: [ERROR] "build" is an unrecognized command. I also cannot update, it says: Error encountered during update Error extracting zip file - /var/folders/6d/tt6h4psx7xs13ctl_x4j25j40000gn/T/mobilesdk-3.1.2.GA-osx archive is not a ZIP archive


  1. Motiur Rahman 2013-09-16 Hi Angela King, you check your internet connection and Uninstall the node and again try to update or Uninstall the titanium studio and reinstall it then try to update. Thanks
  2. Angela King 2013-09-16 Thanks, I have actually done this 3 times & I always get the same error. What can I try next?
  3. Shak Hossain 2013-09-17 Please try to download the file directly from this http://builds.appcelerator.com.s3.amazonaws.com/index.html#3_1_X and then unzip it. Place it to your application folder and then run the installation. If you still get this, please try to post a Question in our Developer Q/A here http://developer.appcelerator.com/questions/newest .
  4. Ritu Agrawal 2013-12-23 [~ange666] We have resolved a number of installation and upgrade issues with the latest release 3.2.0 GA Studio and SDK. I would appreciate if you can give it a try and let us know if you can reproduce the issue. We would be happy to troubleshoot this issue with you.

JSON Source