Titanium JIRA Archive
Alloy (ALOY)

[ALOY-1054] Windows: Alloy compiler does not show error details when using from Ti Studio

GitHub Issuen/a
Affected Version/sn/a
Fix Version/sn/a
ReporterMauro Parra-Miranda
AssigneeTim Poulsen


*Shouldn't it show at least the file name?* \[INFO\] : Executing Alloy compile: alloy.cmd compile xxxxx\app --config platform=android,version=0,simtype =none,devicefamily=none,deploytype=development \[DEBUG\] : .__ .__ \[DEBUG\] : _____ | | | | ____ ___.__. \[DEBUG\] : \__ \ | | | | / _ < | | \[DEBUG\] : / __ \| |_| |_( <_> )___ | \[DEBUG\] : (____ /____/____/\____// ____| \[DEBUG\] : \/ \/ {color:red} \[ERROR\] Application Installer abnormal process termination. Process exit value was 1 \[ERROR\] : Error parsing XML file. \[ERROR\] : Alloy compiler failed {color}




  1. Ritu Agrawal 2014-05-28

    I tried to reproduce this issue but for me I can see all the details. I just corrupted my xml file. Here is the console output.
       [INFO] :   Executing Alloy compile: /usr/local/bin/node /usr/local/bin/alloy compile /Users/ragrawal/Documents/Titanium_Studio_Workspace/BugTC4150_alloy/app --config platform=android,version=0,simtype=none,devicefamily=none,deploytype=development
       [DEBUG] :         .__  .__                
       [DEBUG] :  _____  |  | |  |   ____ ___.__.
       [DEBUG] :  \__  \ |  | |  |  /  _ <   |  |
       [DEBUG] :   / __ \|  |_|  |_(  <_> )___  |
       [DEBUG] :  (____  /____/____/\____// ____|
       [DEBUG] :       \/                 \/
       [DEBUG] :  Alloy 1.3.1 by Appcelerator. The MVC app framework for Titanium.
       [DEBUG] :  
       [DEBUG] :  ----- CONFIGURATION -----
       [DEBUG] :  raw config = "platform=android,version=0,simtype=none,devicefamily=none,deploytype=development"
       [DEBUG] :  platform = android
       [DEBUG] :  version = 0
       [DEBUG] :  simtype = none
       [DEBUG] :  devicefamily = none
       [DEBUG] :  deploytype = development
       [DEBUG] :  project path = /Users/ragrawal/Documents/Titanium_Studio_Workspace/BugTC4150_alloy
       [DEBUG] :  app path = /Users/ragrawal/Documents/Titanium_Studio_Workspace/BugTC4150_alloy/app
       [DEBUG] :  
       [DEBUG] :  ----- CONFIG.JSON -----
       [DEBUG] :  {
       [DEBUG] :    "dependencies": {},
       [DEBUG] :    "sourcemap": true,
       [DEBUG] :    "autoStyle": false,
       [DEBUG] :    "adapters": [
       [DEBUG] :      "localStorage",
       [DEBUG] :      "properties",
       [DEBUG] :      "sql"
       [DEBUG] :    ]
       [DEBUG] :  }
       [DEBUG] :  
       [DEBUG] :  ----- CLEANING RESOURCES -----
       [DEBUG] :  Removing orphaned controllers...
       [DEBUG] :  Removing orphaned models...
       [DEBUG] :  Removing orphaned styles...
       [DEBUG] :  Removing orphaned sync adapters...
       [DEBUG] :  Removing orphaned assets and libs...
       [DEBUG] :  
       [DEBUG] :  ----- BASE RUNTIME FILES -----
       [DEBUG] :  
       [INFO] :   ----- MVC GENERATION -----
       [INFO] :   [global style] loading from cache...
       [INFO] :   [index.xml] view processing...
       [INFO] :     style:      "index.tss"
       [INFO] :     view:       "index.xml"
       [ERROR] :  Error parsing XML file.
       [ERROR] :  source code out of document root
       [ERROR] :  @#[line:3,col:9]
       [ERROR] :  Alloy compiler failed
       [ERROR] Application Installer abnormal process termination. Process exit value was 1
    You can attach your project and we will be happy to take a look.
  2. Fix Please 2014-05-28

    Try the markup below. I've just checked the both 3.2.2.GA and 3.2.3.GA. The both give me the error like as in the initial report.
       	<Window class="container">
  3. Ritu Agrawal 2014-05-29

  4. Fix Please 2014-05-30

    Seems the things are even worse. The error messages are not the same if one builds the same code/markup several times. See the video attached.
  5. Zoltan Vandor 2014-06-05

  6. Zoltan Vandor 2014-06-05

    I just realized that @Ragrawal used the command line. Running compile from CLI, I do get a proper error message: [ERROR] Error parsing XML file. [ERROR] end tag name: View is not match the current start tagName:Window [ERROR] @#[line:6,col:30]
  7. Federico Casali 2014-06-13

    Reproducible on Windows 8 TiSDk 3.3.0.v20140612101712 Appcelerator Studio 3.3.0.v20140612101712 CLI 3.3.0-rc Alloy 1.4.0-rc On MAC OS X error details are correctly shown in the Studio too.
  8. Praveen Innamuri 2014-06-19

    I tried running the same command (on terminal) on both Mac and Windows - and I noticed that Alloy fails to output additional console information about the missing tag/attribute on Windows. I did also notice that on Mac, it has additional info logs related to Configuration, Config.JSON, Cleaning resources, Base runtime files, MVC generation. However, it didn't output any of these compile phases on Windows.
  9. Tim Poulsen 2014-06-19

    [~pinnamuri] If you look at the output from the Windows logs vs the Mac logs, you'll see that the file name info is output at the [INFO] log level, while the errors are output at either the [DEBUG] or [ERROR] levels. It appears that Studio on Windows is incorrectly filtering out the [INFO] level messages, while Studio on Mac is not. This is in keeping with Zoltan's comment that the file name is output on Windows when using the CLI.
  10. Praveen Innamuri 2014-06-19

    [~skypanther] Referring to my previous comment, I tried the same build command on terminal for both Windows and Mac platforms. I can verify that the build command does not output the fileName on Windows. Can you try it on Windows and confirm please ?
  11. Tim Poulsen 2014-06-19

    I resurrected my Windows machine and can confirm this issue. I don't seem to get any [INFO] level logging output. Still investigating the root cause.
  12. Tim Poulsen 2014-06-19

    Further troubleshooting: alloy compile --config platform=mobileweb and alloy compile --config platform=android show the error messages and all log output as expected. ti build -p mobileweb (or android) does not show the error message as described in the ticket. I confirmed that my CLI is configured to show Trace level messages and tried setting it to all the other levels, with and without colors. None of those changes get the error messages to show up. Perhaps this is a CLI issue?
  13. Ingo Muschenetz 2014-06-24

    [~cbarber], thoughts?
  14. Chris Barber 2014-06-24

    [~ingo] Couple of thoughts. First is that we need people to enable TRACE output. There are details we are missing. Second, the Alloy CLI should be deprecated and Alloy should be a CLI plugin. I've said this over and over again.
  15. Tim Poulsen 2014-06-24

    I just submitted a PR. I'm waiting for Jenkins to run before merging.
  16. Tim Poulsen 2014-06-24

    PR https://github.com/appcelerator/alloy/pull/461 (PR has been merged to the 1_4_X and master branches) Functional test: *Perform these steps on Windows* 1. Create a new Alloy project. 2. Edit app/views/index.xml and delete the closing tag 3. From the command line, enter ti build -p mobileweb The error output should include the file name. You could also build for Android. *Perform those same steps on OS X* to confirm that the change didn't break anything on that platform. You can build for any platform to test.
  17. Tim Poulsen 2014-06-26

    Reopening because the fix is causing compilations to fail on iOS:
        [INFO]  Found Alloy app in /Users/timpoulsen/repos/skypanther_alloy/test/projects/Harness/app
        [INFO]  Executing Alloy compile: /usr/local/bin/node /usr/local/bin/alloy compile /Users/timpoulsen/repos/skypanther_alloy/test/projects/Harness/app --config platform=ios,version=0,simtype=none,devicefamily=universal,deploytype=development,target=simulator
        [DEBUG] /usr/local/lib/node_modules/titanium/node_modules/longjohn/dist/longjohn.js:185
        [DEBUG] throw e;
        [DEBUG] ^
        [DEBUG] TypeError: Cannot call method 'on' of null
        [DEBUG] at /Users/timpoulsen/repos/skypanther_alloy/test/projects/Harness/plugins/ti.alloy/hooks/alloy.js:142:18
  18. Tim Poulsen 2014-06-26

    New PR https://github.com/appcelerator/alloy/pull/462 Merged to master and 1_4_X branches
  19. Federico Casali 2014-07-12

JSON Source