Titanium JIRA Archive
Alloy (ALOY)

[ALOY-873] ListView data binding test app fails on second start

GitHub Issuen/a
ResolutionCannot Reproduce
Resolution Date2014-03-27T14:53:01.000+0000
Affected Version/sAlloy 1.3.0, Alloy 1.2.2
Fix Version/sAlloy 1.4.0
ComponentsDocumentation, Models
Labelsalloy, data-binding, ios7, listview, qe-3.2.0, qe-testadded
ReporterJan Helleman
AssigneeTony Lukasavage


iOS 7 fails on the following demo: https://github.com/appcelerator/alloy/tree/master/test/apps/models/binding_listview The first time the rows are rendered right. When the app is restarted, the items are not rendered right. This also happens with sections. I have attached two images, showing before close and after opening for a second time. Inserting or resetting the model does not seem to help. This happens on both devices and simulator. It does not matter whether it is compiled with iOS sdk 6.1 or 7. Android has no problem handling the same case.


iOS Simulator Screen shot Oct 9, 2013 4.50.37 PM.png2013-10-09T14:53:57.000+000066357
iOS Simulator Screen shot Oct 9, 2013 4.51.08 PM.png2013-10-09T14:53:57.000+000026513


  1. Tony Lukasavage 2013-11-07

    This app will not work correctly until TIMOB-13678 is resolved as I am experiencing the exact same error when the app attempts to repopulate the app. I may just need to indicate that this TIMOB issue exists in the app for the time being.
  2. Jan Helleman 2013-11-29

    It's not really that important, but how did the reporter end up to be someone else than me? I had a hard time finding this issue because it didn't show up as me being the reporter :)
  3. Tony Lukasavage 2013-12-03

    I just added you as the reporter. Sometimes when our support staff moves a ticket from TC to ALOY, it seems the original reporter gets lost. I'll see if we can find the root of that.
  4. Sabil Rahim 2014-03-20

    [~tlukasavage] I tried reproducing this issue with current master, 3.2.2.GA, 3.2.1.GA could not reproduce it. I may be missing something here. When you get time could you please retest this test and let us know.
  5. Tim Poulsen 2014-03-27

    I cannot reproduce this issue with 3.2.2.GA, Alloy 1.3.1 on the iOS 7.1 simulator. Steps: launch app, Cmd+Shift+H, double-Cmd+Shift+H, swipe up to kill app, Cmd+Shift+H, launch app -> same rendering. I can repeat this multiple times and I get the same item rendering each time. In another test, I launched the app, reset the data, added three "template 3" items, then fully-closed the app & relaunched. I get the proper item rendering each time.
  6. Tim Poulsen 2014-03-27

    Resolving this as Cannot Reproduce based on my testing with 3.2.2.GA & Alloy 1.3.1.
  7. Pragya Rastogi 2014-05-14

    Verified that the issue is no more reproducible on: OSX: 10.9.2 Xcode: 5.1.1 Studio - SDK -3.3.0.v20140513191712 acs-1.0.14 alloy-1.4.0-dev npm-1.3.2 titanium-3.3.0-dev titanium-code-processor-1.1.1

JSON Source