Titanium JIRA Archive
Alloy (ALOY)

[ALOY-886] Android: some widget samples does not show with TiSDK 3.2.X

GitHub Issuen/a
Resolution Date2013-12-05T21:10:51.000+0000
Affected Version/sAlloy 1.3.0, Alloy 1.2.2
Fix Version/sAlloy 1.3.0, 2013 Sprint 24, 2013 Sprint 25
ComponentsSamples & Templates, Titanium SDK, Widgets
Labelsqe-3.2.0, regression
ReporterFederico Casali
AssigneeTony Lukasavage


Problem description

widget_buttongrid, widget_bouncylogo and widget_drawer samples does not show up when launched on Android using the latest TiSDK 3.2.X. The screen is just black showing nothing else. Applies to both alloy versions 1.2.2 and 1.3.0-alpha6 Using TiSDK 3.1.3.GA, the samples are displayed correctly. Samples available here: https://github.com/appcelerator/alloy/tree/master/test/apps/widgets/widget_bouncylogo https://github.com/appcelerator/alloy/tree/master/test/apps/widgets/widget_buttongrid https://github.com/appcelerator/alloy/tree/master/test/apps/widgets/widget_drawer


  1. Ingo Muschenetz 2013-11-27

    Since there are more widgets this applies to, and you can select those widgets from Studio, we likely need a fix. Tony can you give a clue as to why this might be the case and if it's a SDK issue?
  2. Tony Lukasavage 2013-11-27

    I'll take a look. At first glance, though, they all use animation. Wasn't there changes made to Android animations for TiSDK 3.2.0? I'll try to narrow it down in the meantime.
  3. Tony Lukasavage 2013-11-27

    widget_bouncylogo just worked fine for me with TiSDK 3.2.0, Alloy 1.3.0, and android emulator 4.2.2 (API 17). I'll check the others as well, but I haven't yet seen an issue here.
  4. Tony Lukasavage 2013-11-27

    I can't reproduce this error. All 3 of these apps run fine using TiSDK 3.2.0, Alloy 1.3.0, and the 4.2.2 (API 17) android emulator. I'm closing this for now, but will re-open if provided with more details as to how to re-create the initial issue that you saw.
  5. Lokesh Choudhary 2013-12-05

    After verification on my machine I saw the following observations:

    Alloy 1.3.0-beta & Ti SDK 3.2.0.v20131204220843:

    We see nothing but black screen/window -- Fail

    Alloy 1.2.2 & Ti SDK 3.2.0.v20131204220843:

    We see nothing but black screen/window -- Fail

    Alloy 1.2.2 & Ti SDK 3.1.3.GA:

    We see an animation of the alloy icon coming down from the top of the screen --- Pass


    Appcel Studio : Ti SDK : 3.2.0.v20131204220843 Mac OSX : 10.8.5 Alloy : 1.3.0-beta & 1.2.2 CLI - 3.2.0-beta
  6. Tony Lukasavage 2013-12-05

    [~lokeshchdhry] what did you test this on? I stated above that I could not reproduce and I need to know specifically what emulator and/or device you used to generate these results. You also didn't mention what app you were testing, but I'm assuming it was the bouncylogo.
  7. Lokesh Choudhary 2013-12-05

    Hi Tony, Yes,I used the bouncy logo app. I tested this on Mac OSX 10.8.5. I used Samsung Galaxy S4 running android 4.2.2 device to test. Let me know if you need any more info. My Environment: Appcel Studio : Ti SDK : 3.2.0.v20131204220843 Mac OSX : 10.8.5 Alloy : 1.3.0-beta & 1.2.2 CLI - 3.2.0-beta
  8. Tony Lukasavage 2013-12-05

    This is going to boil down to an Android platform issue. I'm finding that by simply removing "height: Ti.UI.FILL" in the main window's style that everything starts to work. There must have been a change in how this was handled in Android between 3.1.3 and 3.2.0.
  9. Tony Lukasavage 2013-12-05

    PR: https://github.com/appcelerator/alloy/pull/283 Updated on both master and 1_3_X. I was finally able to reproduce. The widgets themselves are fine. It was the common structure of the containing app that caused the issue. The details of the issue are logged in TIMOB-15905. I have worked around that issue in this ticket. All 3 apps listed should work as expected now on both 3.1.3 and 3.2.0.
  10. Federico Casali 2013-12-05

    Verified the samples are now shown correctly. TiSDK 3.2.0.v20131204220843 CLI 3.2.0-beta Alloy 1.3.0-beta Android Nexus Galaxy 4.3 Android Simulator 4.2 Closing.

JSON Source