Titanium

[ALOY-1192] iOS: apps crashing using TiSDK 3.5.X

GitHub Issuen/a
TypeBug
PriorityCritical
StatusClosed
ResolutionFixed
Resolution Date2014-12-15T22:36:05.000+0000
Affected Version/sAlloy 1.5.1
Fix Version/sn/a
ComponentsModels
Labelsqe-3.5.0, regression
ReporterFederico Casali
AssigneeTim Poulsen
Created2014-12-02T02:01:15.000+0000
Updated2014-12-15T22:42:10.000+0000

Description

Problem description

Using TiSDK 3.5.X, a number of Alloy apps are installed but crashing when run with no crash log. Still investigating to narrow down the root of the issue. Using TiSDK 3.4.1.GA apps run as expected. Also runs fine on Android with TiSDK 3.5.X

Sample apps

Following sample apps (that could be found in the Alloy repo: https://github.com/appcelerator/alloy/tree/master/test/apps) have been confirmed crashing when run on iOS device: . models/sql_preload . models/sql_no_migrations . models/properties . advanced/momentjs . Field Service sample app (as imported from Studio GA) Attached a few logs for apps that crashes. There is no [ Error ] displayed in the Console log. Also attached is the Crash log taken from Xcode relative to the Harness template using the 'sql_no_migrations' sample code.

Note

Following sample apps do not crash and work as expected when launched from iOS device: .advanced/commonjs .advanced/nativemodules .basic/simple .basic/builtins .default Alloy template from Studio

Attachments

FileDateSize
alloyModelCollection.zip2014-12-02T23:14:30.000+00003516245
fieldServiceCrash.txt2014-12-02T02:01:15.000+00003069
Harness 12-1-14, 5-47 PM.crash2014-12-02T02:01:15.000+000040284
momentsjSampleCrash.txt2014-12-02T02:01:15.000+00002230
Screen Shot 2014-12-02 at 9.47.54 AM.png2014-12-02T14:51:39.000+000074670
sql_no_migrationsCrash.txt2014-12-02T02:01:15.000+00002450

Comments

  1. Ingo Muschenetz 2014-12-02 Once we isolate a native test case from this, this should become a TIMOB ticket.
  2. Tim Poulsen 2014-12-02 I'm unable to reproduce this building from the CLI. See screenshot for my CLI environment. I have Xcode Version 6.1 (6A1052d) but I checked the AppStore and I do not see a 6.1.1 version available.
  3. Tim Poulsen 2014-12-02 Tested with Appcelerator Studio 3.4.1 and apps build & run in the simulator without error.
  4. Federico Casali 2014-12-10 As a result of TIMOB-18135 resolution, this issue is not reproducible anymore and all the samples reported in this Jira ticket now work as expected. TiSDK 3.5.0.v20141208122514 Alloy 1.5.1.GA CLI 3.4.1.GA Appcelerator Studio 3.4.1.GA Xcode 6.1.1 iPhone 5 (iOS 8.1.1)
  5. Ingo Muschenetz 2014-12-15 Resolving as fixed based on comments.
  6. Federico Casali 2014-12-15 Closing as not reproducible anymore.

JSON Source