[ALOY-510] Issue using 'alloy run' (deprecated) for building on iOS device

GitHub Issuen/a
ResolutionWon't Fix
Resolution Date2013-03-08T22:58:12.000+0000
Affected Version/sAlloy 1.0.0
Fix Version/sn/a
ReporterFederico Casali
AssigneeTony Lukasavage


Problem description

Not possible to specify the iOS certificates and run the app con device when running 'alloy run -p ios -T device'


From Terminal in any project folder, run 'alloy run -p ios -T device'. The user is informed that the command is actually deprecated and to use 'titanium build' instead (alloy run will be removed with 1.1.0). The user is then prompted with which 'iOS Developer Certificate' to use. However, the cursor is not placed in the same line and pressing the return key does not generate the list of the available certificates, nor fillin in the certificate name produce any consequence. Using 'ti build -p ios -T device' works fine as expected.


  1. Tony Lukasavage 2013-02-08 I'm content to leave this as is since "alloy run" is deprecated as of 1.0.0 and will be removed in 1.1.0 in favor of using "titanium build" directly. Thoughts?
  2. Federico Casali 2013-02-08 The behavior I expect when encountering a 'deprecated' feature is that it still works as expected but I get a warning that will be soon replaced (or removed) in the upcoming release. I would then discontinue using the deprecated feature for the next rev. Since the deprecated feature should still function, it seems like we should fix this. However, it seems also acceptable to have 'alloy run' notify the user of the deprecation, inform to use instead 'titanium build' and then go right back to the prompt without executing any other action.
  3. Tony Lukasavage 2013-02-09 I guess I wasn't as concerned about this because it *_never_* worked from "alloy run". That being the case, that it never worked for ios device builds, do you still think it needs to support device builds?
  4. Federico Casali 2013-02-14 'Alloy run' is no longer mentioned in the docs (http://docs.appcelerator.com/titanium/latest/#!/guide/Alloy_Quick_Start-section-34636229_AlloyQuickStart-CompileandRun ), I think we can lower the severity.
  5. Tony Lukasavage 2013-03-08 "alloy run" is deprecated and will soon be removed, probably in Alloy 1.1.0

JSON Source