Titanium JIRA Archive
Alloy (ALOY)

[ALOY-813] Unicode characters display as a text string rather than the character

GitHub Issuen/a
Resolution Date2014-06-03T17:32:53.000+0000
Affected Version/sAlloy 1.4.0, Alloy 1.2.1
Fix Version/sAlloy 1.3.0, Alloy 1.2.2, 2013 Sprint 18
LabelsAlloy, qe-testadded, regression
ReporterDaniel Sefton
AssigneeTim Poulsen


I just upgraded to Alloy 1.2.1 and now unicode characters defined in an xml attribute in the alloy view display as a text string rather than the character. I use this technique for icons contained within a custom font file. Doesn't work (but worked before Alloy upgrade)
<Label id="actionDl" class="actIcon" text="\ue012" right="5dp"/>
Works now
<Label id="actionDl" class="actIcon" right="5dp">\ue012</Label>




  1. Tony Lukasavage 2013-08-30

    [~dsefton] did this regression appear between 1.2.0 and 1.2.1?
  2. Steve Gardner 2013-09-02

    I'm pretty sure my Alloy was up to date before upgrading to 1.2.1 but I hadn't worked on this app for a week or two so there might have been an Alloy update between the last build and current one. Sorry I can't be more specific.
  3. Tony Lukasavage 2013-09-03

    PR (master): https://github.com/appcelerator/alloy/pull/236 commit (1_2_X): https://github.com/appcelerator/alloy/commit/9d3143fe57f4679fa645d74d94dced6e22a9644f test app: https://github.com/appcelerator/alloy/tree/master/test/apps/testing/ALOY-813 Run the test app and ensure that you get a screen that looks like the attached screenshot (from ios). You should see no character escape sequences in the app.
  4. Federico Casali 2013-09-04

    Verified as fixed. Titanium SDK 3.1.3.v20130903160805 Alloy 1.2.X branch Appcelerator Studio CLI 3.1.2.GA Node 0.10.13 Closing.
  5. Priya Agarwal 2014-06-02

    Reopening the issue as not getting the expected result. Appc-Studio: sdk:3.3.0.v20140530163312 acs:1.0.14 alloy:1.4.0-beta npm:1.3.2 titanium:3.3.0-beta2 titanium-code-processor:1.1.1 xcode:5.1.1 Device:iPhone5c(v7.1.1),Nexus7(v4.4.2),Nexus5(v4.4.2),LG-P970(v4.0.4) OS:Maverick(10.9.2) On iOS it is working fine. For Android not getting the expected screenshot. Please refer to attached screenshot.
  6. Tim Poulsen 2014-06-03

    The \ue012 character appears to not be supported on Android. Try the test case using \u2764 (a heart) instead. It works fine for me. http://www.fileformat.info/info/unicode/char/e012/fontsupport.htm doesn't list Droid Sans or Roboto as supporting the e012 character Perhaps installing this app will help you determine which fonts are supported on your android devices: http://www.madore.org/~david/programs/UnicodeMap.html
  7. Federico Casali 2014-06-03

    Following last Tim's comment, using the suggested unicode \u2764 it works fine on iOS, Android and Mobileweb. TiSDK 3.3.0.v20140603032057 Alloy 1.4.0-beta Appcelerator Studio CLI 3.3.0-beta2 Closing.

JSON Source