[ALOY-884] Errors removing orphaned sync adapters when using a widget-specific sync adapter

GitHub Issuen/a
Resolution Date2013-11-24T15:39:35.000+0000
Affected Version/sn/a
Fix Version/sAlloy 1.3.0, 2013 Sprint 24
ComponentsModels, Tooling
Labelsalloy, cli, compile, qe-port, sync, widgets
ReporterFokke Zandbergen
AssigneeTony Lukasavage


After upgrading to Alloy 1.3.0-alpha3 I get errors when building a project that worked fine with Alloy 1.2.x:
[DEBUG] Removing orphaned controllers...
[DEBUG] Removing orphaned models...
[DEBUG] Removing orphaned styles...
[DEBUG] Removing orphaned sync adapters...
[DEBUG] fs.js:760
[DEBUG]   return binding.unlink(pathModule._makeLong(path));
[DEBUG]                  ^
[ERROR] : EPERM, operation not permitted '/Users/zandbergen/dev/apps/VBG/Resources/iphone/alloy/sync/nl.fokkezb.titabs.gcal
The problem seems to be that I have widgets that ship with their own custom sync adapter. The sync adapter is provided via:
After the build stops on this error, the file *does* exist under the displayed Resources path.


  1. Tony Lukasavage 2013-11-23 PR: https://github.com/appcelerator/alloy/pull/278 test app: https://github.com/appcelerator/alloy/tree/master/test/apps/testing/ALOY-884 Functional test "Compile" = "alloy compile --platform ios"

    Compile the test app once. This should work without error.

    Compile the test app again. This should again work without error.

    Prior to this fix, step 2 would cause the error shown in the description above. It is not necessary to do any runtime evaluation to confirm that this bug is fixed.
  2. Fokke Zandbergen 2013-11-23 It seemed fixed, but of course cleaning up is only relevant the second run and then it still crashes. When I run the ALOY-884 test using jake and then compile the generated Harness project a second or more time is passes. So I need to check what the difference is with my project(s).
  3. Fokke Zandbergen 2013-11-23 If you run just alloy compile --platform ios it passes, but when you run ti build -p ios multiple times it fails after the first build. This is true for both my project and the Harness project generated by jake app:run dir=testing/ALOY-884. Note that after generating the project you need to change to its root and run ti build -p ios from there because jake will just generate a new project every time.
  4. Tony Lukasavage 2013-11-24 re-opening to look at [~fokke]'s case
  5. Tony Lukasavage 2013-11-24
  6. Fokke Zandbergen 2013-11-25
  7. Federico Casali 2013-12-05 Cannot reproduce also following latest comments from Tony and Fokke. TiSDK 3.2.0.v20131204220843 CLI 3.2.0-beta Alloy 1.3.0-beta Closing.

JSON Source