Titanium JIRA Archive
Appcelerator Community (AC)

[AC-140] Can't update Appcelerator Studio on Mac - username is wrong

GitHub Issuen/a
ResolutionNot Our Bug
Resolution Date2015-12-08T09:23:20.000+0000
Affected Version/sn/a
Fix Version/sn/a
Labelsosx, studio4
AssigneeMostafizur Rahman


After installing the new appcelerator studio, I got an update message for the code analyzer. Clicking install, it poped a dialog to enter my "system password". However the username is wrong (grebulon) and grayed out so I cannot change it. (see attachment) I guess I'm supposed to enter my mac user name, which is not grebulon. Not sure where it gets the user name from and what I should do to change it.




  1. Praveen Innamuri 2015-05-26

    Did you try providing the system (sudo) password in the dialog and verify whether that would help you to install dependencies? Studio tries to fetch the username from the underlying platform, and if that fails for any reason, then it gets the username using the whoami command, and that's exactly what you see in the dialog. Please provide us the workspace logs, if Studio fails to handle the system/sudo password in the update prompt dialog.
  2. grebulon 2015-05-27

    Please, I'm not that dumb. Of course I tried the sudo password, and whoami returns my real osx username which is NOT grebulon. "Studio tries to fetch the username from the underlying platform" - well, it does that wrong. Just leave the user name field enabled and let the user change the name if he wants to. I'm not posting the studio logs here, so give me an email to which to send it.
  3. grebulon 2015-05-27

    After some more searching, I found that the dialog shows my Full Name as indicated in the Users and Group preference dialog. You should put the user name not the full name, and in any case, leave the user name enabled in the dialog.
  4. Amimul Hossain 2015-09-20

    Hello [~buddyguards], are you still facing the problem in latest studio build 4.3.0? You can manually install Code analyzer Using NPM "sudo npm install -g titanium-code-processor". Reply with your needs, Thanks.
  5. grebulon 2015-09-20

    I've worked around that as mentioned in the comment above, by changing my full name in the Mac preferences. Still the bugfix should be to enable the user name field.

JSON Source