Titanium JIRA Archive
Appcelerator Community (AC)

[AC-1432] Issues with Cloud login in server

GitHub Issuen/a
Resolution Date2014-05-17T20:56:49.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsTitanium SDK & CLI
ReporterPaul Walker
AssigneeNeeraj Gupta


There was a scheduled update of the cloud server yesterday. and before the update my login and check user email calls worked fine. Today they do not. IF however I create a user through the my.appcelerator web interface i can login with it. Just not a user created through the ti.cloud.js Is there a current issue with the cloud server and the login calls? the call is pretty much the example call. cloud.Users.login({ login: "username", password: "password" }, function.... and it returns with "invalid email/username and password" yet they are in the cloud as i can see them through the web service.


  1. Jacob Avlund 2014-05-17

    We're seeing similar problems here as well. An app that worked fine yesterday cannot log in users anymore. We tried creating a new user through the admin interface, but cannot log in with that user either. Response (HTTP status code 401): { "meta": { "status": "fail", "code": 401, "cc_code": 1000, "message": "Invalid email/username or password." } }
  2. Joseph Sachs 2014-05-17

    Having the same issue, not with all of our ACS Apps, but some of them only. "Invalid email/username or password." on login.
  3. Neeraj Gupta 2014-05-17

    We are investigating this issue right now. Appears to be an issue after the planned upgrade yesterday.
  4. Neeraj Gupta 2014-05-17

    We have rolled out a fix the User login issue. Let us know if you see any other issue.
  5. Peter Ladis 2014-05-17

    We are still having issues. It appeared to work, and then it stopped. It appears as if I'm getting a 200 response on the login....however I get a timeout...which then causes nothing to work.
  6. Paul Walker 2014-05-17

    Do you have an ETA? Back against the wall for a submission and will fail unless it can connect to the server.
  7. Paul Walker 2014-05-17

    Still having intermittent problems. esp with the cloud.app... web service to manage the DB. every other refresh is an "oh noo"... load balancing problems?
  8. Neeraj Gupta 2014-05-17

    There is a large backlog of requests after we resolved the login issue. It would take some time to drain these requests. We are monitoring the queue closely.
  9. Paul Walker 2014-05-17

    do you have an eta on when the backlog might be cleared? the service is still very flaky and i have a lot of issues using the web service manage the db..
  10. Paul Walker 2014-05-17

    clicking on the cloud service manager on https://cloud.appcelerator.com/apps now ALWAYS returns the "oh no.." is it time to be looking at an alternative solution as this is not good commercially?
  11. Neeraj Gupta 2014-05-17

    We are running into an index issue with MongoDB causing performance and hence these intermittent issues. Please rest assured that our engineering team is working on the solution right now and we hope to resolve it soon.
  12. Neeraj Gupta 2014-05-17

    We have resolved intermittent performance issues now so please try it out and let us know if you run into any other issue.
  13. Joseph Sachs 2014-05-17

    Thanks guys for the prompt fix! All is working now :)
  14. William Diaz 2014-05-18

    How you mark the issue resolved when I posted a message 5 hours ago that still not working???
  15. Neeraj Gupta 2014-05-18

    We have received confirmation from multiple users that the original issue has been resolved and that's why this ticket is marked resolved. Please open a new ticket if you are running into any issue as that would be a different issue.
  16. William Diaz 2014-05-18

  17. William Diaz 2014-05-18

    Just one more note: The errors occurs when launch the app: {"code":200,"status":"ok","method_name":"queryCustomObjects","page":1,"per_page":100,"total_pages":0,"total_results":0}} You would notice that returns 200 but the custom objects returns zero results and not token.
  18. Neeraj Gupta 2014-05-18

    We have asked you for more information and you have not provided none. There is no point in updating these tickets if you are not planning to provide a test case that can reproduce this issue. We would not update this ticket further and look into your issue only if you provide a test case as part of TC-4144.
  19. William Diaz 2014-05-18

    So frustrating. Unbelievable

JSON Source