Titanium JIRA Archive
Appcelerator Community (AC)

[AC-148] CLI 4.0.0 returning error

GitHub Issuen/a
ResolutionNeeds more info
Resolution Date2015-11-13T19:29:34.000+0000
Affected Version/sn/a
Fix Version/sn/a
ComponentsAppcelerator CLI
ReporterRon Piwetz
AssigneeShak Hossain


After installing appcelerator through npm, when I run appc setup, I get this error: "Download server is not currently available. Please re-try your install again in a few moments. If you continue to have this problem, please contact Appcelerator Support at support@appcelerator.com."


  1. Ron Piwetz 2015-06-02

    I uninstalled all of my npm packages, uninstalled Appcelerator Studio, uninstalled node.js. Installed Node.js 0.12.4, updated to npm 2.11.0, installed the appcelerator package, ran appc setup, same error.
  2. Ingo Muschenetz 2015-06-02

    [~rpiwetz] Could you please try the steps here http://docs.appcelerator.com/platform/latest/#!/guide/Appcelerator_CLI_Troubleshooting-section-43299941_AppceleratorCLITroubleshooting-SubmittingaBug and attach the log file you have? Are you perhaps behind a proxy?
  3. Ron Piwetz 2015-06-03

    As I suspected...the proxy is not set, so I get many of these errors: D:\test>cmd /C "set DEBUG=* && appc use -l trace" > log.txt appc:bin install bin is undefined +0ms appc:bin main subcommand use +5ms appc:use use called with args [ 'use' ], getLatest=0 +2ms appc:util request {"url":{"protocol":"https:","slashes":true,"auth":null,"host ":"software.appcelerator.com","port":443,"hostname":"software.appcelerator.com", "hash":null,"search":null,"query":null,"pathname":"/api/appc/list","path":"/api/ appc/list","href":"https://software.appcelerator.com/api/appc/list"},"proxy":"", "headers":{"user-agent":"Appcelerator CLI/4.0.0 (win32)","host":"software.appcel erator.com"}} +182ms appc:util request error +98ms { [Error: read ECONNRESET] code: 'ECONNRESET', e rrno: 'ECONNRESET', syscall: 'read' } How do I set the proxy when I can't run 'appc config'?
  4. Praveen Innamuri 2015-06-03

    [~rpiwetz] Can you run https://software.appcelerator.com/api/appc/list in the browser and see whether you are getting the correct response ? If not, then I believe your machine is not reachable to the endpoint, either due to firewall or network issues. We realized that it is a issue to set the config when the core packages are not yet installed. As a workaround, can you copy the below snippet (replace with your proxy server) in to your [HOME_DIR]\.appcelerator\appc-cli.json (for ex: C:\Users\<user>\.appcelerator\appc-cli.json).
         "proxyServer": "http://proxy.com"
  5. Ron Piwetz 2015-06-03

    had just figured this out and was about to post it here. I am now receiving a self-signed cert error, but will keep working with support to get that solved. Thank you!!
  6. Rakhi Mitro 2015-09-16

    Not sure if this is still an issue for you. Please follow the steps below and let us know. 1)For *"cert untrusted*" you might try updating Node away from 0.10.34 (0.10.37 works) as there was a bug with that version of Node. 2)If NPM or node install fails, check permissions on install locations. If you ARE behind a proxy, you should install the NPM portion of the Appcelerator CLI, then run this command on Mac: *HTTP_PROXY=http://proxy.com:port appc use latest*. Once again, please insert your proxy server and port information. If you use "https", then substitute that in place of "http" and "HTTP" in the commands above. Thanks

JSON Source