Titanium JIRA Archive
Appcelerator Community (AC)

[AC-2063] I can't install NodeJS, Titanium CLI and Alloy + I can't test apps on my iPhone anymore

GitHub Issuen/a
Resolution Date2013-03-18T17:51:23.000+0000
Affected Version/sn/a
Fix Version/sn/a
Reporterelvira pompili
AssigneeCarter Lathrop


Steps to Reproduce

Dear Sirs, Finally I tried to install NodeJS, Titanium CLI and Alloy on my Mac, but there is a big problem with my system password, which is empty (I set it as empty). Then when the NPM Packages Installer ask me to fill in the Password I just type Enter, but I got an error (Sorry, try again). What can I do to solve this problem? Moreover, after updating Titanium to the last version and making this attempt to install NodeJs etc. I can't able to transfer my apps to my iPhone anymore! When I click on the Run on iOS device, nothing happens. The windows in which you have to choose the provisioning profile hasn't been shows anymore. Can you help me please? It's very important. Thank you and kind regards. Elvira

Actual Result

NPM Packages Installer …. Password:(I TYPE ENTER BECAUSE MY SYSTEM PASSWORD IS EMPTY!) Sorry, try again. ...

Expected Result

Password:(ENTER) Ok!


  1. Carter Lathrop 2013-03-05

    Hello Elvira, Have you tried setting your system password to a string of characters and then entering that? This will let us know if the problem is with an empty password or with something else. Please try changing your password and let us know of the results. Regards, Carter
  2. elvira pompili 2013-03-05

    Dear Carter, Thank you for your reply. Is this the procedure to set the password: http://support.apple.com/kb/ht1274 Resetting a user's password in OS X Lion and Mountain Lion Kind regards, Elvira
  3. Carter Lathrop 2013-03-06

    Yes, that is the right method. In addition to changing your password, the most common fix to these types of problems is to completely reinstall Titanium. Please try this and let me know of your results. Carter
  4. elvira pompili 2013-03-07

    Dear Carter, Thank you for your suggestions. I already tried to completely reinstall Titanium, but I have got the same results (I can't install NodeJS, Titanium CLI and Alloy + I can't test apps on my iPhone anymore). That's the reason why for the moment I decided to install the previus version of Titanium (2.0.2). Now I can test my apps on my iPhone, as in the past. But I really would like to work with the latest version of Titanium. Then I have to change my system password. This changement won't affect other programs or something else in my Mac, will it? Thank you again and kind regards, Elvira
  5. Carter Lathrop 2013-03-07

    No, the password change will not affect any other programs. Also which OS version of Mac are you using?
  6. elvira pompili 2013-03-08

    Hello Carter, Thank you for your prompt reply. I have a Mac Book Pro with Mac OS X Version 10.7.5 I'm waiting for your reply and then I'll try to set the password (as explained here: http://support.apple.com/kb/ht1274) and to reinstall Titanium (last version). Kind regards, Elvira
  7. Carter Lathrop 2013-03-08

    Thats fine, I am using the same version. Go ahead and try the password change and reinstall titanium. Everything should be in order. Make sure you are downloading titanium from our main site: appcelerator.com. Regards, Carter
  8. elvira pompili 2013-03-18

    Dear Carter, Now everything is ok. I changed the system password and successfully upgraded Titanium to the lastest version (3.0.2). Thank you very much for your help. Kind regards, elvira
  9. Carter Lathrop 2013-03-18

    Elvira, Glad everything worked out for you. Closing this ticket now. Kind Regards, Carter

JSON Source