Titanium JIRA Archive
Appcelerator Community (AC)

[AC-5708] Cloud.Emails.send not sending emails

GitHub Issuen/a
Resolution Date2018-04-23T23:22:08.000+0000
Affected Version/sAppcelerator Studio 4.5.0
Fix Version/sn/a
ReporterEmmanuel Francis
AssigneeShak Hossain


I have successfully setup the SMTP. Then I have called Cloud.Emails.send with valid recipient email address. API call also return below response: {"success":true,"error":false,"meta":{"status":"ok","code":200,"method_name":"emailFromTemplate"}} But I do not receive any email. I am testing in "Development" environment.


Screen Shot 2018-04-22 at 2.49.01 PM.png2018-04-22T09:21:46.000+0000142540


  1. Mostafizur Rahman 2018-04-22

    Hello [~efrancis], Thanks for sharing with us. Can you please share the screenshot of your dashboard which displays the issue?
  2. Emmanuel Francis 2018-04-22

    I didn't get you what exactly you want me to share from the dashboard? I think the dashboard will have the API keys, I don't think its good idea to share the API keys here. I am sharing the log screenshot of logs !Screen Shot 2018-04-22 at 2.49.01 PM.png|thumbnail! I have a questions, is it required to have paid plan to test sending emails using email template and SMTP setup? Can I test emails while in Indie plan in development mode. I am asking this because when SMTP is setup I did receive an email with subject "[AMPLIFY Platform] Mobile Backend Services SMTP Test", but it does not work when calling Cloud.Emails.send
  3. Emmanuel Francis 2018-04-22

    I tried with production API key too but it does not work.
  4. Sharif AbuDarda 2018-04-22

    Hello, Can you please share your SMTP setup info? Make sure you checked the spam folder. Thanks.
  5. Emmanuel Francis 2018-04-23

    Thanks for the reply. I am able to resolve the issue. It seems that Gmail was blocking emails. Initially, I setup SMTP by enabling "less secure apps access your account". Also allows access to security check prompts too. But wasn't receiving any emails. Then I have created App password and used it in SMTP. Now everything works fine. App password should be the correct way to use Gmail SMTP.
  6. Sharif AbuDarda 2018-04-23

    Thanks for letting us know. Closing this.
  7. Emmanuel Francis 2018-05-19

    I am still struggling this to work perfectly. Google starts blocking Appcelerator to access SMTP. I have setup 2 step verification and also generated an app password. I have entered the app password successfully. It worked for some time and then again got blocked. Below is the email from google: Google just blocked someone from signing into your Google Account support@karpoolclub.com from an app that may put your account at risk. Less secure app Saturday, May 19, 2018 8:42 AM (PT) Boardman, OR, USA* Don't recognize this activity? If you didn't recently receive an error while trying to access a Google service, like Gmail, from a non-Google application, someone may have your password. Is Appcelerator server is not accessing securely and does not support the latest security standards?

JSON Source