Titanium JIRA Archive
Appcelerator Community (AC)

[AC-5853] iOS: App freezes on splash screen in adhoc build.

GitHub Issuen/a
ResolutionNot Our Bug
Resolution Date2018-11-16T13:58:21.000+0000
Affected Version/sn/a
Fix Version/sn/a
ReporterSharif AbuDarda
AssigneeShak Hossain


Hello, I have an app, which is when building normally for simulator or device it works fine. The app launch in the simulator and device. The issue is when I do an adhoc build. After the package is generated, I install the app to my device through Xcode (My device is listed in the provisioning profile) and tried to launch the app, the app opens and freezes on the splash screen in the device. Similar issue also sent through testflight. Any idea why?


Console log 8-23.rtf2018-08-23T18:07:22.000+000018776
Crash log 10-31 (1).rtf2018-11-07T16:57:56.000+000024010
Crash log 8-23.png2018-08-23T18:07:11.000+0000105430
Dashboard Symbols.app.dSYM.zip2018-11-14T16:40:51.000+00004505715
Dashboard Symbols.ipa2018-11-15T15:21:14.000+00007414569
Dashboard Symbols.ipa2018-11-14T20:33:52.000+00007497754
Dashboard Symbols.ipa2018-11-14T19:36:13.000+00007440119
Dashboard Symbols.ipa.zip2018-11-09T02:02:34.000+00007373942
Screen Shot 2018-11-06 at 9.53.41 PM.png2018-11-08T16:56:58.000+000040850
Screen Shot 2018-11-06 at 9.54.14 PM.png2018-11-08T16:57:04.000+000019894
Screen Shot 2018-11-15 at 9.56.43 AM.png2018-11-15T15:03:51.000+000012838
Screen Shot 2018-11-15 at 9.58.08 AM.png2018-11-15T15:03:59.000+000019955


  1. Hans Knöchel 2018-08-21

    Missing environment (SDK version, CLI version, iOS version, Xcode version), missing logs, missing crash report. Resolving as Invalid for now.
  2. Sharif AbuDarda 2018-08-27

    Hello [~hknoechel], can you please update on this? Anything else needed?
  3. Sharif AbuDarda 2018-10-20

  4. Jan Vennemann 2018-11-07

    We still need more input to investigate this. On what device is this happening? iOS version? Logs from the device? Crash reports? If the freeze happens on iOS 12, have they tested with the build posted to TIMOB-26391? Anything that could give us a clue, really.
  5. Marc Favreau 2018-11-08

    This problem persists (at least 6 months now). It was last tested on an iPhone, 12.0.1, with the same freeze found with the adhoc build. It DID NOT register a log! Please see the images (empty log AND the phone's info) just added and please HELP! Using the latest updates.
  6. Jan Vennemann 2018-11-08

    [~mfavreau], can you provide the IPA so we can test this? Without any logs or crash report it's hard to understand what might be going on in your app.
  7. Marc Favreau 2018-11-08

    Of course. Can it be posted here??
  8. Sharif AbuDarda 2018-11-08

    Hello [~mfavreau], You can privately send email to Jan if you think that's more secure. Thanks.
  9. Marc Favreau 2018-11-09

    Sent compressed via mac@dashboardsymbols.com. And now I see how I could have attached it here, so I did... [^Dashboard Symbols.ipa.zip]
  10. Marc Favreau 2018-11-13

    Is anything happening??
  11. Jan Vennemann 2018-11-14

    [~mfavreau], we can't install the IPA because our devices are obviously not registered for your ad-hoc distribution. Do you have an app store targeted IPA you can share or can you provide the project? What third-party frameworks or modules are you using?
  12. Marc Favreau 2018-11-14

    I should have guessed. I now have two avenues. I am NOT sure I can grab an IPA built for distribution, but I will do a build and try. Otherwise, it would be simple to register a device.PLEASE don't take a week to respond...
  13. Marc Favreau 2018-11-14

    Ok, I've got a new build but no idea how to snag the new ipa. Someone pls advise or give me a device uuid.
  14. Jan Vennemann 2018-11-14

    [~mfavreau], please contact me at jvennemann@axway.com so i can give you my device id. That's probably the easiest way to move forward here.
  15. Marc Favreau 2018-11-14

    Ok, this one holds the right profile. Massive pain in the a$$ putting this together. [^Dashboard Symbols.ipa]
  16. Vijay Singh 2018-11-15

    [~mfavreau] It looks your problem is related to certificate similar to TIMOB-26448. https://stackoverflow.com/questions/52440492/ios-app-wont-run-on-device-any-more-under-ios-12-unrecoverable-ct-signature-is . https://forums.developer.apple.com/thread/106711 See if this can help you. Thanks!
  17. Jan Vennemann 2018-11-15

    [~mfavreau], we took another look at your project. So a few things: * Update to the latest SDK. You are using 5.2.0 which is over two years old and has no support for iOS 12. Change the sdk version in your tiapp.xml to this: <sdk-version>7.4.1.GA</sdk-version> * Enable main thread by adding this to your tiapp.xml: <property name="run-on-main-thread" type="bool">true</property> After updating the SDK to 7.4.1.GA and enabling run on main thread i was able to build and run you project on Simulator, Device and as an adhoc-build. Please verify you project settings and also your certificates as mentioned by Vijay above.
  18. Marc Favreau 2018-11-15

    Ok, so first, thanks for the feedback, and just for fun, Vijay, I thought you were still playing golf... Seriously, I can and will change signing to "Defaults". Actually thought about doing this and didn't for no good reason. But MORE seriously, Jan you have to explain how it is possible that sdk 5.2 is in use. The software has updated itself a dozen times this year alone and 7.4.1 is installed!!! In fact, I cannot choose an sdk below 7.0.1 (I tried a month ago to see if it would help)! Something else is in play causing 5.2 to somehow 'stick'. How and where do I look to address this?? Thank you...
  19. Jan Vennemann 2018-11-15

    Read my comment again, i specifically explained where you set the SDK version. In your project's tiapp.xml within the <sdk-version> tag. Just because the SDK is installed does not mean it's set in your project. Every project has it's own version constraint so you can easily have multiple projects with different version of our SDK.
  20. Marc Favreau 2018-11-15

    Sorry Jan, but its not going to be that simple. Please see the two screen shots. !Screen Shot 2018-11-15 at 9.56.43 AM.png|thumbnail! !Screen Shot 2018-11-15 at 9.58.08 AM.png|thumbnail!
  21. Jan Vennemann 2018-11-15

    You send us a copy of your project which has <sdk-version>5.2.0.GA</sdk-version>. Please double check the dropbox link you send me yesterday.
  22. Marc Favreau 2018-11-15

    I just ran a new version changing signing to Defaults without success, and it freezes on my older iPad (which, as far as I am concerned is VERY important). Ipa attached. [^Dashboard Symbols.ipa]
  23. Marc Favreau 2018-11-15

    Sorry, we overran each other. I'll check the drop box copy.
  24. Marc Favreau 2018-11-15

    Ok, I'm sorry, not sure how why or what, but I sent an old copy. This link goes to the new one (from this morning...). https://www.dropbox.com/s/l1w9il9e8es725t/Dashboard%20Symbols.zip?dl=0
  25. Marc Favreau 2018-11-15

    Its too bad, Thought we were on to something.
  26. Vijay Singh 2018-11-16

    [~mfavreau] In alloy.js please replace line
        	Alloy.Globals.ad = Alloy.createController("admob").getView();
        	Alloy.Globals.ad = Alloy.createController("adMob").getView();
    as the file under controllers is adMob.js (Capital 'M'). It should fix your problem. And it was giving me error message on screen when I simply run, not adhoc build. I am surprised if you were not getting the error. Please let me know if you face any other issue. Thanks!
  27. Marc Favreau 2018-11-16

    Well many thanks. It actually works, and on my old device. And so simple. You won't believe it, but the start of this -- 6+ months ago -- involved a request for help getting admob to deliver ads on the iOS platform... Thank you again.

JSON Source