Titanium JIRA Archive
Appcelerator Community (AC)

[AC-6123] Unable to Save SMTP Email settings

GitHub Issuen/a
Resolution Date2019-02-05T16:28:37.000+0000
Affected Version/sAppcelerator Studio 4.5.0
Fix Version/sn/a
ComponentsAppcelerator Dashboard
Labelsemail, smtp
ReporterGlen Bentley
AssigneeShak Hossain


I'm trying to configure Email for an Appcelerator project. Initially planning to use gmail for testing, but getting "The SMTP settings are not valid" when trying to Save the configuration. I've confirmed PW, tried different ports and authentication options. This issue looks to have bee reported multiple times, but I've not seen a resolution. The documentation does not look to provide a good example re: settings.


Screen Shot 2019-02-01 at 1.50.03 PM.png2019-02-02T18:45:37.000+0000200222
Screen Shot 2019-02-04 at 3.46.58 PM.png2019-02-04T23:49:39.000+0000199992
Screen Shot 2019-02-04 at 9.30.00 AM.png2019-02-04T17:40:35.000+0000332483
Screen Shot 2019-02-04 at 9.32.15 AM.png2019-02-04T17:40:35.000+0000284429


  1. Rakhi Mitro 2019-02-03

    Hello, Thanks for reporting this. Can you try on a different browser and if that happens can you take a screenshot and share with us.
  2. Glen Bentley 2019-02-04

    I tried on both Chrome and Safari - same error (screenshots attached). Below are the very simple steps I follow: 1. From Axway Appcelerator Studio - Create a New Mobile App Project * Select Classic – Default Project * Enable Platform Services and Hyperloop (Titanium SDK 7.5.0.GA) * Run app in iphone Simulator (works) 2. Log into Dashboard (https://platform.axway.com/#/app) * Select newly created apps Mobile Backend Services from Projects * Select Configuration – Configuration – Email menu option * Fill out information as shown in screen shots * Select Save Changes – receive error – “The SMTP settings are not valid” Hoping I'm simply missing a step. !Screen Shot 2019-02-04 at 9.30.00 AM.png|thumbnail! !Screen Shot 2019-02-04 at 9.32.15 AM.png|thumbnail!
  3. Ewan Harris 2019-02-04

    [~gbentley] Try 587 for the port, I'm using that currently with a gmail address and it works. Not that you also have to turn on "Less secure app access" in https://myaccount.google.com/security to allow the login flow to work
  4. Glen Bentley 2019-02-04

    Afraid I've turned on "Less secure app access" (see screenshot) and get the same error. Were you able to follow steps above to create a quick test app? I'm assuming (hoping) a step is missing. !Screen Shot 2019-02-04 at 3.46.58 PM.png|thumbnail!
  5. Ewan Harris 2019-02-05

    [~gbentley], I'm currently using the email service with a gmail in production. From your screenshots it looks like you're using 587 with "Login auth. I'm using "Plain" auth with 587. Note that gmail was silently blocking all logins from the email service until I reset my password, so I think maybe try the below * Reset gmail password * Set the email config to use ** Port: 587 ** Authentication: Plain And see how that goes.
  6. Glen Bentley 2019-02-05

    Awesome, that did the trick. Thanks.

JSON Source